If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[meta] Provide a way to transmit large JSON objects across workers without janking

RESOLVED DUPLICATE of bug 873293

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 873293
5 years ago
4 years ago

People

(Reporter: Yoric, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

In some circumstances, we have to deal with huge JSON objects (up to 50Mb) that we wish to transmit to workers prior to writing them to disk. Unfortunately, that's pretty large and probably not feasible without jank for the time being (no benchmarks so far).

Opening this bug to track ideas on the topic.
A conversation with jorendorff seems to indicate the following avenues:
- provide some mechanism of "prepared statements" that can be used for efficient (de)serialization;
- publish the low-level serialization API to JavaScript.
Flags: needinfo?(jorendorff)
Flags: needinfo?(jorendorff)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 873293
You need to log in before you can comment on or make changes to this bug.