After hitting home button during video playback and relaunching app, video is a black screen

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: adora, Assigned: daleharvey)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g18+ affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 715873 [details]
Log from an instance where neither audio or video worked after relaunching the app

I've seen this across several 3rd party apps from SporTV.  Approximately 25% of the time, video in these apps also seems to freeze within the first few seconds, guaranteeing this error when the user tries to relaunch the app.  Per Harald, this developer is is using Web Activities to launch videos in the Gaia video player.

Link to example app: https://marketplace.firefox.com/reviewers/apps/review/flamengo-sportv

To duplicate:

1. Tap the Video icon at the bottom of the screen (may have to hit the House icon and then the Video icon again)
2. Tap a video to start playing
3. Hit the hardware home button to go back to the launcher
4. Relaunch the app
5. Try to watch another video

Observe: I'm consistently able to duplicate that audio plays, but video does not play.  Once or twice during the dozen or more times I repeated this, audio also didn't play.  

Other notes: Once the phone is in an error state, all apps by this developer exhibit the same symptoms.  Fully closing and relaunching the app doesn't resolve the issue, have to reboot the phone.  

Found in builds: 2013-02-18, 2013-02-13
(Reporter)

Comment 1

6 years ago
Possibly related:  repeating these same steps in the Video app causes an app crash when reaching the end of the video.

Crash report:  https://crash-stats.mozilla.com/report/index/bp-7efa9953-f650-474a-9222-8eb8a2130220
Logcat issues worth noting:

E/GeckoConsole(  108): [JavaScript Error: "NS_ERROR_FAILURE: No canonical URL set up." {file: "jar:file:///system/b2g/omni.ja!/components/captivedetect.js" line: 238}]

E/GeckoConsole(  429): [JavaScript Error: "not well-formed" {file: "app://{d5f48f61-9095-4447-854e-cbcb53fb8399}/videos.html" line: 14 column: 42 source: "    <div data-role="content" data-iscroll>"}]

E/GeckoConsole(  483): [JavaScript Warning: "HTTP load failed with status 400. Load of media resource http://flashvideo.globo.com/h264/globosat/3/sportv/redacao_sportv/2013/02/19/2414773-web360.mp4 failed." {file: "app://video.gaiamobile.org/view.html" line: 0}]
(In reply to Lisa Brewster [:adora] from comment #1)
> Possibly related:  repeating these same steps in the Video app causes an app
> crash when reaching the end of the video.
> 
> Crash report: 
> https://crash-stats.mozilla.com/report/index/bp-7efa9953-f650-474a-9222-
> 8eb8a2130220

That crash looks like bug 840154. It's on central, needs to be uplifted to b2g18.
Dale - Any thoughts on this bug? Specifically the notable logcat messages in comment 2?

Updated

6 years ago
tracking-b2g18: --- → ?
Triage believes this needs some attention, we're going to track and assign to Dale to investigate further.
Assignee: nobody → dale
status-b2g18: --- → affected
tracking-b2g18: ? → +
(Assignee)

Comment 6

6 years ago
Still unable to reproduce and the app has changed significantly since this was opened.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.