Calling createAnswer on a Peer Connection immediately after creation - error callback fires with "3", should be "INVALID_STATE"

RESOLVED DUPLICATE of bug 834270

Status

()

Core
WebRTC
RESOLVED DUPLICATE of bug 834270
5 years ago
5 years ago

People

(Reporter: jsmith, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 715877 [details]
Testcase

Steps:

1. Load the attached test case

Expected:

We should get an error callback with INVALID_STATE.

Actual:

An error callback fires with "3" as the parameter. This is probably due to the fact that we're not providing the enumerated name here and instead, providing the numerical enumerated equivalent. I'm going to go ahead and guess there's probably other ways to reproduce this pretty easily with other error codes.

Let's fire a "useful" error code back at the developer.
(Reporter)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 834270
You need to log in before you can comment on or make changes to this bug.