Closed Bug 842924 Opened 8 years ago Closed 7 years ago

Localization issue with reset period control

Categories

(Firefox OS Graveyard :: Gaia::Cost Control, defect, P2)

defect

Tracking

(blocking-b2g:leo+, b2g18 verified, b2g-v1.1hd fixed)

RESOLVED FIXED
1.1 QE4 (15jul)
blocking-b2g leo+
Tracking Status
b2g18 --- verified
b2g-v1.1hd --- fixed

People

(Reporter: flod, Assigned: salva)

References

Details

(Keywords: l12y, Whiteboard: [LeoVB+])

Attachments

(3 files)

English strings: Monthly, Weekly, Never.
Italian strings: Ogni mese, Ogni settimana, Mai.

Even if I choose to use adverbs it doesn't get shorter (Mensilmente, Settimanalmente).

With the current layout I don't think this is localizable in many languages.
Problem is still present (Unagi, build 2013-06-25).
Keywords: l12y
blocking-b2g: --- → leo?
Italian is not a v1.1 language according to internal docs - are you aware of other impacted languages?
blocking-b2g: leo? → -
Some examples that I doubt fit in this design (es, pt-BR, de seem to have shorter strings this time, I wonder if they had to compromise for it)

pl
monthly = Co miesiąc
weekly = Co tydzień

el
monthly = Μηνιαία
weekly = Εβδομαδιαία

nl
monthly = Maandelijks
weekly = Wekelijks

ru
monthly = Ежемесячно
weekly = Еженедельно
Attached image Polish screenshot
Polish screenshot.

Other languages (e.g. pt-BR) has issues with the name of the day (not sure why Polish is using numbers here).
Flags: needinfo?(akeybl)
Requesting again blocking->leo?
blocking-b2g: - → leo?
Flags: needinfo?(akeybl)
(In reply to Francesco Lodolo [:flod] from comment #4)

> Other languages (e.g. pt-BR) has issues with the name of the day (not sure
> why Polish is using numbers here).

It's because in the screenshot, the "monthly" options is selected.  If you select "weeky", the names of days don't fit either.
leo+ for fixing for launch languages.
blocking-b2g: leo? → leo+
So what is the desired way of fixing this. Broader select field ?
I guess that's up to the UX team, but for me the only safe way out of this is to have one line for the label and another one for the listbox (we have space below).
Priority: -- → P2
Target Milestone: --- → 1.1 QE4 (15jul)
(In reply to Francesco Lodolo [:flod] from comment #9)
> I guess that's up to the UX team, but for me the only safe way out of this
> is to have one line for the label and another one for the listbox (we have
> space below).

Sounds nice to me. Trying to sync with UX to achieve the best result for this strategy.
Assignee: nobody → salva
Hi guys,

we had a similar problem in the clock app when setting up the alarms, so we decided to do a small update to these buttons. Basically we should not be using the small buttons aligned to the right. The problem, as you've been suffering, is that it's really difficult to fit any value within a button that small, so we decided to go with a regular button containing the value with a label on top of it.

You can check the visuals through this link: https://bug867038.bugzilla.mozilla.org/attachment.cgi?id=750660

Thanks!
when is the patch expected to land for this?
(In reply to Sergi from comment #11)
> Hi guys,
> 
> we had a similar problem in the clock app when setting up the alarms, so we
> decided to do a small update to these buttons. Basically we should not be
> using the small buttons aligned to the right. The problem, as you've been
> suffering, is that it's really difficult to fit any value within a button
> that small, so we decided to go with a regular button containing the value
> with a label on top of it.
> 
> You can check the visuals through this link:
> https://bug867038.bugzilla.mozilla.org/attachment.cgi?id=750660
> 
> Thanks!

Thank you very much Sergi!

(In reply to chris hofmann from comment #12)
> when is the patch expected to land for this?

This weekend.
Attachment #771977 - Flags: review?(francisco.jordano)
Comment on attachment 771977 [details]
Avoid l10n issues by providing wider selects

Simple and non risky change,

Thanks Salva!
Attachment #771977 - Flags: review?(francisco.jordano) → review+
Master: 89d2ec965d3c7422359ca383b40c26a738610ba3
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Is this going to land on v1 train as well?
It should, it is leo+
Uplifted 89d2ec965d3c7422359ca383b40c26a738610ba3 to:
v1-train: 322435efe0e69bc0b19982f6cc4e02964426cff3
Can you please provide steps to verify this fix.
Whiteboard: [LeoVB+]
Verified, fixed on leo Moz RIL
Environmental Variables
Build ID: 20130723070209
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/68fb0a2e0114
Gaia: ffe25bfdf0e71c820ca710cb61fb8306564a8f4e
Platform Version: 18.1

Issue does not reproduce reset period control is not too narrow and fits all the string into the textbox ... please ignore comment 20
v1.1.0hd: 322435efe0e69bc0b19982f6cc4e02964426cff3
You need to log in before you can comment on or make changes to this bug.