Firefox 17, 18 and 19 are rendering Flash much slower than earlier versions

RESOLVED DUPLICATE of bug 843635

Status

()

Core
Plug-ins
RESOLVED DUPLICATE of bug 843635
5 years ago
5 years ago

People

(Reporter: macster_smart, Unassigned)

Tracking

19 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20121024073032

Steps to reproduce:

I upgraded to newer versions of Firefox just to discover this annoying BUG that perpetuates through them. :(


Actual results:

Firefox is having an issue starting with version 17 that perpetuates through versions 18 and 19 and the issue is that it renders Flash content in pages much slower than earlier Firefox versions.
I'm using some websites that make use of Flash content pretty intense so this problem was very obvious from the start. I have uninstalled and installed new Flash versions just to make sure there's not a problem with the Flash player that I'm actually using version 10.3.183.48, and there's not a Flash plugin issue but a Firefox one.
I installed every new version of Firefox 17, 18 and lately 19 just to check if this BUG disappeared but then I had to uninstall them and switch back to Firefox 16.0.2 which doesn't seem to have this problem and works faster and better than the above mentioned versions. 
So I've noticed this BUG on this website called Chaturbate which is an adult webcam streaming site that uses Flash to show webcams. With Firefox versions 17, 18 and 19 if I enter a room/page to see a webcam the webcam stream that's running on Flash is displaying images very slow like aprox 5 frames/second compared to Firefox 16.0.2 that I'm using that runs the webcam stream much faster usually at full frame speed.
Even in Fullscreen the cams seem to run a little slower and choppy in versions 17, 18 and 19 compared to Firefox version 16.0.2.
This issue needs to be fixed or else I have no option but to stick with version 16.0.2 of Firefox.

The hardware acceleration in Firefox is turned off by default since it doesn't work on my setup, and regarding Flash I see that on Youtube videos when Flash content runs in page it says on "Show video info" "software video rendering, software video decoding" and when I switch the video on Fullscreen it says "accelerated video rendering, software video decoding"

My setup is pretty old but still running like a champ lol: Win XP SP3, Athlon XP 2600+ single core, ATI Radeon 9600 Pro, and 1.25 GB RAM.
Firefox extensions that I'm using:
- Firegestures
- Grab and Drag
- Tab Mix Plus
- Adblock Edge
I call these the best extensions since they give me so much functionality and speed in using Firefox on a daily basis. :)


Expected results:

It should have worked flawlessly. :)
(Reporter)

Updated

5 years ago
Version: 16 Branch → 19 Branch

Updated

5 years ago
Component: Untriaged → Plug-ins
Product: Firefox → Core
Please don't file the same bug repeatedly, you can always comment on one of your bugs if you want to add information.
Duping to the bug with more comments.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 843635
You need to log in before you can comment on or make changes to this bug.