Closed Bug 842972 Opened 7 years ago Closed 7 years ago

infinite exceptions regarding chrome://global/content/devtools/dbg-transport.js :: DT_onOutputStreamReady

Categories

(DevTools :: Debugger, defect, P2)

x86_64
Windows 7
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 732553

People

(Reporter: Optimizer, Assigned: past)

Details

I get this exception infinitely :

[17:16:07.630] [Exception... "Component returned failure code: 0x80470002 (NS_BASE_STREAM_CLOSED) [nsIOutputStream.write]"  nsresult: "0x80470002 (NS_BASE_STREAM_CLOSED)"  location: "JS frame :: chrome://global/content/devtools/dbg-transport.js :: DT_onOutputStreamReady :: line 94"  data: no] @ chrome://global/content/devtools/dbg-transport.js:94


STR (The one that I am sure of) :

1) Open the Firefox OS Simulator using its dashboard.
2) After the simulator starts, click on the "Connect" button on the dashboard, the DevTools connect screen will show up with the correct port number.
3) Connect, Accept any dialog that appears, then choose the "chrome://browser/content/shell.xul" to connect.
4) Remote DevTools show up.
5) Close the demote detools window.
6) Go to the dashboard page of Firefox OS Simulator again.
7) Press connect again and start up the remote devtools again following step 3.
8) See the webconsole starts flooding with the error mentioned above.

(Using latest Nightly, Firefox OS Simulator version 2.0)
This problem occurs because we try to write on every call to onOutputStreamReady.  According to the docs:

https://developer.mozilla.org/en-US/docs/XPCOM_Interface_Reference/nsIOutputStreamCallback#onOutputStreamReady%28%29

onOutputStreamReady is called whenever is the stream is writable or closed.  So, this is called when the stream is closed, at which point we try to write to the stream, and poof...exception.
Assignee: nobody → past
Priority: -- → P2
This should be fixed by bug 732553.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 732553
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.