Variables view should emit notifications whenever it is updated

RESOLVED DUPLICATE of bug 867458

Status

()

Firefox
Developer Tools: Debugger
P3
normal
RESOLVED DUPLICATE of bug 867458
5 years ago
5 years ago

People

(Reporter: msucan, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Writing tests for variables view could be much easier if it would emit notifications whenever scopes/variables/properties are added/edited/deleted or when the whole hierarchy is changed (commitHierarchy).

In bug 808370 we've added EventEmiter-based notifications whenever the vview is updated within the web console. This could be done at vview level, IIANM.
(Reporter)

Updated

5 years ago
Blocks: 843091
Priority: -- → P3
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 867458
You need to log in before you can comment on or make changes to this bug.