Closed Bug 843040 Opened 8 years ago Closed 8 years ago

xulrunner nsinstall command fails symlink create due to file exists

Categories

(Firefox Build System :: General, defect)

20 Branch
x86
macOS
defect
Not set
blocker

Tracking

(firefox20+ fixed, firefox21+ fixed)

RESOLVED FIXED
mozilla20
Tracking Status
firefox20 + fixed
firefox21 + fixed

People

(Reporter: jhopkins, Assigned: glandium)

References

Details

Attachments

(1 file)

This build failure is currently blocking Firefox 20.0b1:
------
/builds/slave/rel-m-beta-xr_osx64_bld-000000/build/obj-firefox/x86_64/config/nsinstall -L /builds/slave/rel-m-beta-xr_osx64_bld-000000/build/obj-firefox/x86_64/xulrunner/stub -m 755 "xulrunner" "../../dist/bin"
/builds/slave/rel-m-beta-xr_osx64_bld-000000/build/obj-firefox/x86_64/config/nsinstall -t -m 755 "xulrunner" "../../dist/bin"
/builds/slave/rel-m-beta-xr_osx64_bld-000000/build/obj-firefox/x86_64/config/nsinstall: cannot make symbolic link /builds/slave/rel-m-beta-xr_osx64_bld-000000/build/obj-firefox/x86_64/dist/bin/xulrunner: File exists
make[7]: *** [../../dist/bin/xulrunner] Error 1
make[7]: *** Deleting file `../../dist/bin/xulrunner'
make[6]: *** [stub_libs] Error 2
make[6]: *** Waiting for unfinished jobs....
-------


Also seen in aurora: https://tbpl.mozilla.org/php/getParsedLog.php?id=19909031&tree=Mozilla-Aurora&full=1

------
/builds/slave/m-aurora-osx64-xr-000000000000/build/obj-firefox/i386/config/nsinstall -t -m 755 "xulrunner" "../../dist/bin"
/builds/slave/m-aurora-osx64-xr-000000000000/build/obj-firefox/i386/config/nsinstall -L /builds/slave/m-aurora-osx64-xr-000000000000/build/obj-firefox/i386/xulrunner/stub -m 755 "xulrunner" "../../dist/bin"
/builds/slave/m-aurora-osx64-xr-000000000000/build/obj-firefox/i386/config/nsinstall: cannot make symbolic link /builds/slave/m-aurora-osx64-xr-000000000000/build/obj-firefox/i386/dist/bin/xulrunner: File exists
make[7]: *** [../../dist/bin/xulrunner] Error 1
make[7]: *** Deleting file `../../dist/bin/xulrunner'
make[6]: *** [stub_libs] Error 2
make[6]: *** Waiting for unfinished jobs....
-----

However this aurora build did not fail:

https://tbpl.mozilla.org/php/getParsedLog.php?id=19873271&tree=Mozilla-Aurora&full=1
This suggests a bad merge in browser/app/Makefile.in. Can you check the diff between aurora when it was 20 and beta for that file?
Huh? It's a xulrunner build? Why is the objdir obj-firefox when building xulrunner? this is confusing.
That looks similar to bug 812918, but that's supposed to be fixed.
I think this would fix it.
Attachment #716037 - Flags: review?(ted)
Assignee: nobody → mh+mozilla
Attachment #716037 - Flags: review?(ted) → review+
Comment on attachment 716037 [details] [diff] [review]
Set FINAL_TARGET before including rules.mk in xulrunner/stub/Makefile.in

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Longstanding intermittent xulrunner red
User impact if declined: Holds up beta1
Testing completed (on m-c, etc.): This is untested.
Risk to taking this patch (and alternatives if risky): This can't make things worse than they are. And it's NPOTB for Firefox (it's a xulrunner-only change).
String or UUID changes made by this patch: None
Attachment #716037 - Flags: approval-mozilla-beta?
Attachment #716037 - Flags: approval-mozilla-aurora?
Attachment #716037 - Flags: approval-mozilla-beta?
Attachment #716037 - Flags: approval-mozilla-beta+
Attachment #716037 - Flags: approval-mozilla-aurora?
Attachment #716037 - Flags: approval-mozilla-aurora+
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.