If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Plugins manager in add-ons manager doesn't recognize changes to plugin list

RESOLVED DUPLICATE of bug 554780

Status

()

Core
Plug-ins
RESOLVED DUPLICATE of bug 554780
5 years ago
5 years ago

People

(Reporter: blizzard, Unassigned)

Tracking

19 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 716046 [details]
screenshot of extensions manager / plugin pane

I took updates from Apple that included a new Java plugin.  Because Java is evil and not to be trusted I loaded the add-ons pane for plugins after it updated and noticed that Java wasn't listed at all.  I thought that was odd so I loaded about:plugins and noticed that it is listed there.  It's also listed if I go to the plugin update tool, which means it's exposed to content.
(Reporter)

Comment 1

5 years ago
Created attachment 716048 [details]
screenshot of about:plugins
(Reporter)

Comment 2

5 years ago
Created attachment 716049 [details]
screenshot of plugin update page
(Reporter)

Comment 3

5 years ago
Note that I didn't restart Firefox after doing the Java update underneath it.  It's very possible that doing about:plugins refreshed the list of plugins, but the extension manager doesn't use the same method.
(Reporter)

Comment 4

5 years ago
Possibly related to bug #398313?
(Reporter)

Comment 5

5 years ago
Note that after a restart the Java plugin shows up in the extensions/add-on manager/plugin pane.  So this looks like it's just a sync issue.
With it working properly after restart, this is bug 554780, which is fixed in Fx21.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 554780
You need to log in before you can comment on or make changes to this bug.