<applet> root causes "ASSERTION: Should not be initializing plugin without a frame"

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
P3
normal
RESOLVED WORKSFORME
5 years ago
2 years ago

People

(Reporter: Jesse Ruderman, Unassigned)

Tracking

(Blocks: 1 bug, {assertion, testcase})

Trunk
x86_64
Mac OS X
assertion, testcase
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

48 bytes, application/xhtml+xml
Details
4.04 KB, text/plain
Details
(Reporter)

Description

5 years ago
Created attachment 716055 [details]
testcase

###!!! ASSERTION: Should not be initializing plugin without a frame: 'Not Reached', file dom/plugins/base/nsPluginInstanceOwner.cpp, line 2967
(Reporter)

Comment 1

5 years ago
Created attachment 716056 [details]
stack
(Reporter)

Comment 2

5 years ago
I have the "Java Plugin" shim that comes with Mac OS X 10.8, but not Java.

Updated

5 years ago
Priority: -- → P3
So we're creating a frame for the document that is not an object frame:

http://dxr.mozilla.org/mozilla-central/dom/plugins/base/nsPluginInstanceOwner.cpp#l2956

GetPrimaryFrame() succeeds, so we pass the nsObjectLoadingFrame has-frame checks, but bail out because it's not an object frame. This should be harmless due to the bail out, but I'm not sure what the right fix is - other than just refusing to let plugins be the root.

Comment 4

5 years ago
Why is the plugin the root? Don't we automatically add body frames and such? Or is this a problem only because this is xhtml+xml, so we don't follow normal HTML rules?
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #4)
> Why is the plugin the root? Don't we automatically add body frames and such?
> Or is this a problem only because this is xhtml+xml, so we don't follow
> normal HTML rules?

I have no idea.

I tested and this does not happen with object or embed:

> <object type="application/x-test" xmlns="http://www.w3.org/1999/xhtml" />
> <embed type="application/x-test" xmlns="http://www.w3.org/1999/xhtml" />

So something about how we make the frame tree for applet is wrong
No longer reproduces.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: in-testsuite+
Resolution: --- → WORKSFORME

Comment 7

2 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/56cd0fae8910

Comment 8

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/56cd0fae8910
You need to log in before you can comment on or make changes to this bug.