iphonejuegosgratis.com doesn't recognize B2G UA as mobile

RESOLVED INVALID

Status

Tech Evangelism
Mobile
RESOLVED INVALID
5 years ago
3 years ago

People

(Reporter: lmandel, Assigned: karlcow)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [uaoverride] [country-uy] [serversniff] [sitewait] [wptouch], URL)

iphonejuegosgratis.com serves a desktop site to B2G. Bug 823364 added an UA override for this domain. The override should be removed once the domain serves mobile content to B2G. This bug tracks the evangelism for the site to recognize the B2G UA and the removal of the override at that time.
Blocks: 843198
Whiteboard: [uaoverride]
(Assignee)

Comment 1

5 years ago
This site needs to be contacted. 
https://wiki.mozilla.org/Compatibility/Guide#Finding_The_Right_Contact_on_a_Web_site


Opera Mob  + Android  -> Mobile
Firefox    + Android  -> Mobile
Firefox OS + ZTE      -> Desktop

Firefox OS needs to receive the mobile site like other mobile devices.

# Firefox for Android
GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: iphonejuegosgratis.com
User-Agent: Mozilla/5.0 (Android; Mobile; rv:18.0) Gecko/18.0 Firefox/18.0

HTTP/1.1 200 OK
Content-Encoding: gzip
Content-Length: 4992
Content-Type: text/html; charset=UTF-8
Date: Wed, 21 Aug 2013 17:54:07 GMT
Server: Apache
Vary: User-Agent,Accept-Encoding
X-Pingback: http://iphonejuegosgratis.com/xmlrpc.php

# Firefox OS

GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: iphonejuegosgratis.com
User-Agent: Mozilla/5.0 (Mobile; rv:18.0) Gecko/18.0 Firefox/18.0

HTTP/1.1 200 OK
Content-Encoding: gzip
Content-Length: 6869
Content-Type: text/html; charset=UTF-8
Date: Wed, 21 Aug 2013 17:54:59 GMT
Server: Apache
Vary: Accept-Encoding
X-Pingback: http://iphonejuegosgratis.com/xmlrpc.php


We can the site content being very different depending on the user agent

→ http -b GET http://iphonejuegosgratis.com/ User-Agent:"$FOSUA"  | grep -i touch
<link rel="apple-touch-icon" href="http://iphonejuegosgratis.com/wp-content/themes/juegosonlinejugar/favicon.ico">

→ http -b GET http://iphonejuegosgratis.com/ User-Agent:"$FANUA"  | grep -i touch
	<link rel="apple-touch-icon" href="http://iphonejuegosgratis.com/wp-content/uploads/wptouch/custom-icons/Games.png" />
	<link rel="stylesheet" href="http://iphonejuegosgratis.com/wp-content/plugins/wptouch/themes/default/style.css" type="text/css" media="screen" />
#headerbar, #wptouch-login, #wptouch-search {
[… plenty more …]
Whiteboard: [uaoverride] → [uaoverride] [country-uy] [serversniff]
(Assignee)

Comment 2

4 years ago
I suspect a dependency on wptouch
Depends on: 909420
Whiteboard: [uaoverride] [country-uy] [serversniff] → [uaoverride] [country-uy] [serversniff] [contactready]
(Assignee)

Comment 3

4 years ago
In the footer we can see 
"Otro Sitio de Loculandia" -> http://loculandia.com/
Then "Loculandia.com is proudly powered by MyArcadePlugin - WordPress Arcade" -> http://myarcadeplugin.com/
Then Contact page http://myarcadeplugin.com/contact/


sent email with link to https://miketaylr.com/posts/2013/10/firefox-os-and-wptouch.html
Whiteboard: [uaoverride] [country-uy] [serversniff] [contactready] → [uaoverride] [country-uy] [serversniff] [sitewait]
(Assignee)

Updated

4 years ago
Duplicate of this bug: 843130
(Assignee)

Updated

4 years ago
Assignee: nobody → kdubost
Status: NEW → ASSIGNED
Whiteboard: [uaoverride] [country-uy] [serversniff] [sitewait] → [uaoverride] [country-uy] [serversniff] [sitewait] [wptouch]
(Assignee)

Comment 5

4 years ago
Recontacted this time through twitter. 
http://twitter.com/MozWebCompat/status/463929031105081344
Asking to upgrade to the latest WPTouch, now that bravenewcode has made it compatible with Firefox OS
http://www.wptouch.com/bravenewcode/wptouch-adds-new-device-and-browser-support/
(Assignee)

Comment 6

3 years ago
I get a 403 Forbidden both with any browsers.
Let's revisit in a couple of days, and if it persists, I think we will close it as INVALID.


→ http --print hH GET http://iphonejuegosgratis.com/ 'User-Agent:Mozilla/5.0 (Android; Mobile; rv:30.0) Gecko/30.0 Firefox/30.0'

GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate
Host: iphonejuegosgratis.com
User-Agent: Mozilla/5.0 (Android; Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

HTTP/1.1 403 Forbidden
Connection: close
Content-Length: 405
Content-Type: text/html; charset=iso-8859-1
Date: Thu, 18 Dec 2014 10:23:18 GMT
Server: Apache
 

With a nonsense body 403+500

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>403 Forbidden</title>
</head><body>
<h1>Forbidden</h1>
<p>You don't have permission to access /
on this server.</p>
<p>Additionally, a 500 Internal Server Error
error was encountered while trying to use an ErrorDocument to handle the request.</p>
<hr>
<address>Apache Server at iphonejuegosgratis.com Port 80</address>
</body></html>
still forbidden error - let's drop any UA overrides for this site
(Assignee)

Comment 8

3 years ago
The site became invalid. I have 500 Errors. now.

Remove UA override in 1171828
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
(Assignee)

Updated

3 years ago
Blocks: 1171828
You need to log in before you can comment on or make changes to this bug.