Closed Bug 843208 Opened 7 years ago Closed 7 years ago

The aspect ratio of video streams received from a Nexus 4 is wrong

Categories

(Core :: WebRTC: Audio/Video, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 844177

People

(Reporter: florian, Unassigned)

Details

(Whiteboard: [getUserMedia][blocking-gum-][android-gum+][MWCDemo2013])

The aspect ratio of the video stream from the Nexus 4 front camera seems to be 16:10. When we display it locally in a 4:3 frame, it's displayed with margins at the top and bottom. However, at the other end of a call (ie on desktop), the stream is displayed with a 4:3 format; stretched.

http://queze.net/goinfre/n4-macbook-video.png may clarify what I mean, although it's a bit difficult to notice because of the orientation bug.
Whiteboard: [getUserMedia][blocking-gum-][android-gum+]
Whiteboard: [getUserMedia][blocking-gum-][android-gum+] → [getUserMedia][blocking-gum-][android-gum+][MWCDemo2013]
Duplicate of bug 844177?
(In reply to Gian-Carlo Pascutto (:gcp) from comment #1)
> Duplicate of bug 844177?

looks like it.
No longer blocks: android-webrtc
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 844177
You need to log in before you can comment on or make changes to this bug.