Closed Bug 843219 Opened 7 years ago Closed 5 years ago

Linked in confirmation windows not working via https

Categories

(Web Compatibility :: Desktop, defect)

defect
Not set

Tracking

(firefox19-, firefox20-, firefox21-)

RESOLVED WORKSFORME
Tracking Status
firefox19 - ---
firefox20 - ---
firefox21 - ---

People

(Reporter: mbest, Unassigned)

Details

Attachments

(2 files)

Repro steps:

1. Open linked in FX19
2. Enter in a post, hit submit
3. Attempt to accept the confirmation window

The window does not close.

The post is submitted and will show up with a refresh.

The same is true for the delete confirmation, in this case however, the post is not delete.
additional detail:

a post in the above steps referse to the text field at the top with the words "What's on your mind" in lite gray.  Enter in some text there and submit, the following confirmation window can't be closed.

I'm in 19.0
Anthony - can you help find a regression window? This may end up being a TE bug, but we first need to help identify what's breaking and whether there's a workaround.
QA Contact: anthony.s.hughes
I've been unable to reproduce this issue in Firefox 19 on Windows 7. I just set up a new account and when I go to the Home tab there is a grey area near the top called "Share an update...". When I type something in and click the blue Share button it gets posted immediately. I'm not even seeing any "confirmation" window.

Martin, can you please provide more specific details about how you are seeing this. Alternatively, can you try using the mozregression tool to find the regression range yourself?
http://mozilla.github.com/mozregression/

This would likely save us a lot of time.
Flags: needinfo?(mbest)
Keywords: steps-wanted
Martin, are you using any add-ons?
Yes, but I disabled all addons and extensions and retested.  Still the same error although I don't always get the confirmation dialog when posting.  I do however always get the confirmation dialog when deleting a post and it shows the same error.
Flags: needinfo?(mbest)
I have also tried to replicate this but like Anthony I don't see any confirmation window at all. Also on Fx19, Win7.
I tried a few updates and it all seems to be working fine.

A screenshot would tell a thousand words!
Also tested the delete post confirmation box and it worked fine.
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0

In Firefox 19, I cannot reproduce the first issue because I don't see any confirmation window when adding new posts. Although, I cannot delete any updates. If I eventually succeed deleting one update (1 out of 10 times), when I refresh the page, it reverts. The behavior is the same on Firefox 3.6, 4.0, 17 and 18, Chrome (version 25.0.1364.97), Opera (version 12.14) and IE 9.
I'm no longer seeing the confirmation dialog on posting.  I'm not sure if they changed the site between now and then as it no longer seems part of the flow.  The delete seems to be the same dialog with different text and I can reproduce it 100% of the time.

Repro steps for the delete dialog:
Create a short post in the box that says, "what's on your mind and submit"
Refresh the page if the post doesn't appear below it right away
Attempt to delete it
Can't approve the deletion on the popup that appears

I have confirmed that this does work in the latest version of Chrome.
I just tried it in Firefox 19 on Mac OSX Lion and it also failed to Delete there.  Identical symptoms.
(In reply to Martin Best (:mbest) from comment #10)
> Repro steps for the delete dialog:
> Create a short post in the box that says, "what's on your mind and submit"
> Refresh the page if the post doesn't appear below it right away
> Attempt to delete it
> Can't approve the deletion on the popup that appears

I'm not reproducing this at all though there seems to be some discrepancy in what you are describing. I am unable to find "What's on your mind and submit" anywhere in the UI I'm being presented with. 

If I am on the HOME tab I have a box called "Share an update..." which I can use to post updates to my profile feed. If I hover one of my posts I have a delete link. Clicking the delete link presents me with a confirmation overlay and I'm able to click "Yes, please delete it". However I am noticing that the post actually doesn't get deleted.

However, that's not the bug as I understand it. What I understand your issue to be is that the overlay does not respond to your clicks (ie. it does not disappear). Can you please confirm which is the case?
I did some testing with regards to the "Delete not deleting" case and it's reproducible in Firefox 12.0a1 2012-01-01. I've not tried going back any further but I assert that if this did break recently, it's a change on LinkedIn's end and not something we did in Firefox 19.

Martin, please confirm that this is the behaviour you filed the bug against. If so I don't see that we need to track this further, though it might be worth moving over to Tech Evangelism.
Dropping the *wanted keywords for now based on comment 12 and 13.
OS: Windows 7 → All
Hardware: x86_64 → All
So yes, just to confirm.

1. I no longer see a dialog box for approving a status update, I'm not sure what changed between now and when i submitted this bug on that front but I can no longer reproduce that path.
2. I am seeing a dialog appear when I click delete.
3. If I "Yes, please delete it", the dialog box does not close and the post is not deleted.

I'm attaching a screenshot so you can see what I'm seeing where I see the "What's on your mind" box.
Thanks for the screenshots, Martin, hopefully these can help Anthony out more in reproducing and determining the regression window.
(In reply to Martin Best (:mbest) from comment #17)
> Created attachment 718651 [details]
> Screenshot of the dialog box that won't close.
This is the dialog I've been seeing too and it closes for me. 

I don't see any way forward on this bug unless you are willing to track down the regression range yourself. It's fairly straightforward using the mozregression tool:
http://mozilla.github.com/mozregression/

I'm happy to provide guidance as needed.
Keywords: qawanted
Okay, I finally reproduced this. I noticed in your screenshot after the fact that you are on https while I was on http (a small but very important factor). Switching to https://www.linkedin.com I was able to reproduce this. I'll see if I can track down a regression range.
Turns out a picture is worth a 1000 words. ;)  Good to hear you can repro it.
I'm able to reproduce the same behaviour in Firefox 18.0, Firefox 16.0, Firefox 4.0, and Safari 5.1.7. As a result I am not convinced this is a Firefox bug. This bug should be resolved INVALID or moved to Tech Evangelism in my opinion.
Summary: Linked in confirmation windows not working. → Linked in confirmation windows not working via https
Let's move this to tech evang and untrack then.
Assignee: nobody → english-us
Component: General → English US
Product: Firefox → Tech Evangelism
Version: 19 Branch → unspecified
I had no issue creating and deleting things under http and https.
Firefox 32.0.3
Assignee: english-us → nobody
Status: NEW → RESOLVED
Closed: 5 years ago
Component: English US → Desktop
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.