[B2G][Phone][Headphones] Phone mouth piece does not work when the user is using headphones that do not include a microphone.

RESOLVED INVALID

Status

Firefox OS
Gaia
RESOLVED INVALID
5 years ago
2 years ago

People

(Reporter: J Zimbrick, Assigned: baku)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-)

Details

(Reporter)

Description

5 years ago
Repro Steps:

1. Update Unagi device to build 20130220070204.
2. Plug in a pair of headphones that do not include a mic. (I'm using a pair of Panasonic RPHJE120K earbuds.)
3. Make or receive a call from a phone without headphones plugged in, and attempt to talk.
4. Observe that no audio is transmitted from the user with micless headphones plugged in, though the user can hear audio from the other phone in their headphones.

Expected:

User with micless headphones plugged in can hear call audio through their headphones and transmits voice through the microphone on the phone.

Actual:

User with micless headphones plugged in can hear call audio through the headphones, but is completely unable to transmit voice.  It seems that the phone's microphone is disabled when any sort of headphones are plugged in.

Repro Rate:

Appears to be 100%, checked several times on my device as well as on another tester's device with a different set of headphones.

Environmental Variables:

Kernal Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/140d06fc3397
Gaia: b8bd76b1110417ef43a39ae28a2eeffbce1eda11
(Reporter)

Comment 1

5 years ago
Just updating this due to the build change today, still occurring.

Environmental Variables:

Kernal Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/140d06fc3397
Gaia: b8bd76b1110417ef43a39ae28a2eeffbce1eda11
Build ID: 20130220093954
(Reporter)

Updated

5 years ago
Keywords: smoketest

Comment 2

5 years ago
Request P2 escalation. 

This issue fails Mozilla and Commercial Build RILs Smoketest:
Build ID: 20130328070204
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/dc653b5b2339
Gaia: 6dbf0b68622aa80d079fee2af660ddc47f7cd7df
blocking-b2g: --- → leo?

Updated

5 years ago
Assignee: nobody → amarchesini
blocking-b2g: leo? → tef?

Comment 3

5 years ago
(not necessarily a blocker, since this is a fairly uncommon use case, but wanted to get it on tef? triage nonetheless)
Don't think we should block on this one. :dpv, what do you think?
blocking-b2g: tef? → leo?
Flags: needinfo?(dpv)

Comment 5

5 years ago
Hi J Zimbrick,

Could you test this bug with the headphone from Unagi itself? It should be workable.
And please refer to the link as below that Unagi's define of headphone ring is not the same with some others.

http://talk.sonymobile.com/thread/62722
(Reporter)

Comment 6

5 years ago
It does work with the headphones packaged with the unagi, you can hear the other person just fine and your own voice appears to be transmitted through the mic on the headphone line.

The problem is say the user is listening to music on the device through headphones   that do not include a microphone and gets a call, the ring can be heard through the headphones, they can answer the call and hear the person on the other end of the line speak through the headphones, but they won't be able to respond. 
  To be able to speak with the person that they can hear just fine through the headphones, they'll have remove the headphones from their ears and unplug them from the phone, which seems less than ideal to me.

Just plugging in any set of headphones seems to mute the microphone on the phone itself, whether the headphones have a mic or not. Is this a hardware issue, or something that could possibly be changed by software? I'm unsure of how the architecture works, but perhaps their could be a check on the phones having a mic included or not.
Hi, 

Sorry for the late response... 

I agree with Daniel, it seems a quite unusual use case, I think it'd not necessary to block on this. 

Thks!
David
Flags: needinfo?(dpv)
Not blocking the release based on comment 4 & comment 7.
blocking-b2g: leo? → -

Updated

5 years ago
Duplicate of this bug: 853093
Duplicate of this bug: 884036
(Reporter)

Comment 11

5 years ago
Issue no longer appears to be occurring on a Leo running the latest commercial build from the 1.1 branch: 

Build ID: 20130625070217
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/29933d1937db
Gaia: 1436e2778b90bd74635b0b94d1cf8ccb0d71b60c
Platform Version: 18.1
RIL Version: 01.01.00.019.138
Firmware Version: D30008h

When making a call with my personal headphones that do not include a microphone, I could both hear the person calling me through the headphones as well as speak to them through the phone's receiver.

Resolving as works for me.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
Still repros on the Unagi 1.1 mozilla RIL.

Build ID: 20130701070213
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/15923aca6e6d
Gaia: c7472acec84f0d4527cdd6fd555d289e1d3e1d1d
Platform Version: 18.1
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Updated

5 years ago
Keywords: smoketest

Comment 13

4 years ago
This issue is also happening on Buri 1.3 

Environmental Variables:
Device: Buri 1.3 MOZ RIL
BuildID: 20131210004003
Gaia: 3452fbdb5e1bed0cd27cc6173136537a03e8072f
Gecko: e0c328d99742
Version: 28.0a2

Comment 14

3 years ago
I experienced that bug on GP Peak FxOS 2.1.
(Assignee)

Updated

2 years ago
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.