mork asserts on startup setting up global history

VERIFIED DUPLICATE of bug 82590

Status

()

Core
History: Global
VERIFIED DUPLICATE of bug 82590
17 years ago
17 years ago

People

(Reporter: John Gaunt (redfive), Assigned: Alec Flett)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
On my NT box this was just an annoyance, I only recieved this assertions once,
but on my 2k box I can't get past it.

inYarn->mYarn_buf is null in the call to
morkStore::StageYarnAsFarBookAtom(morkEnv* ev, const mdbYarn* inYarn,
   morkAtomSpace* ioSpace)

The char* in nsGlobalHistory::SetRowValue(nsIMdbRow *aRow, mdb_column aCol,
                             const char* aValue) in empty, which looks like it
causes the yarn to be created with everything null.

Going back one more step to CheckHostNameEntries() what I see is that it tries
to get the hostname for on urlObj pointing to a local file. The urlObj doesn't
have a hostname associated with it ( or is an empty string ).

Could this be caused by my trying to run a current build of mozilla with a
profile from 6.01??

Looked through the other bugs and none had this stack trace or assertion on startup.

NTDLL! 77f9eea9()
nsDebug::Assertion(const char * 0x044acbc8, const char * 0x044acad4, const char
* 0x044aca94, int 78) line 290 + 13 bytes
mork_assertion_signal(const char * 0x044acbc8) line 78 + 31 bytes
morkEnv::NewError(const char * 0x044acb30) line 369 + 19 bytes
morkEnv::NilPointerError() line 412
morkStore::StageYarnAsFarBookAtom(morkEnv * 0x03ba2a50, const mdbYarn *
0x0012f56c, morkAtomSpace * 0x03bc8820) line 453
morkStore::YarnToAtom(morkEnv * 0x03ba2a50, const mdbYarn * 0x0012f56c) line 732
+ 20 bytes
morkRow::AddColumn(morkEnv * 0x03ba2a50, unsigned int 136, const mdbYarn *
0x0012f56c, morkStore * 0x03c022a0) line 881 + 16 bytes
orkinRow::AddColumn(nsIMdbEnv * 0x03ba2b68, unsigned int 136, const mdbYarn *
0x0012f56c) line 470
nsGlobalHistory::SetRowValue(nsIMdbRow * 0x03bd07d0, unsigned int 136, const
char * 0x00000000) line 750 + 26 bytes
nsGlobalHistory::CheckHostnameEntries() line 2382
nsGlobalHistory::OpenExistingFile(nsIMdbFactory * 0x03ba29f0, const char *
0x03ba2bc8) line 2242
nsGlobalHistory::OpenDB() line 2167 + 28 bytes
nsGlobalHistory::AddPage(nsGlobalHistory * const 0x03a7d630, const char *
0x03ba2028) line 556 + 11 bytes
nsDocShell::AddToGlobalHistory(nsDocShell * const 0x0384e9b0, nsIURI *
0x03b22af8) line 5524 + 39 bytes
nsDocShell::OnNewURI(nsDocShell * const 0x0384e9b0, nsIURI * 0x03b22af8,
nsIChannel * 0x03b245d0, unsigned int 1) line 4880
nsDocShell::OnLoadingSite(nsDocShell * const 0x0384e9b0, nsIChannel *
0x03b245d0) line 5111
nsDocShell::CreateContentViewer(nsDocShell * const 0x0384e9b0, const char *
0x0012fa44, nsIRequest * 0x03b245d0, nsIStreamListener * * 0x0012fa94) line 3709
nsDSURIContentListener::DoContent(nsDSURIContentListener * const 0x0384ee28,
const char * 0x0012fa44, int 0, nsIRequest * 0x03b245d0, nsIStreamListener * *
0x0012fa94, int * 0x0012fa28) line 119 + 33 bytes
nsDocumentOpenInfo::DispatchContent(nsIRequest * 0x03b245d0, nsISupports *
0x00000000) line 350 + 93 bytes
nsDocumentOpenInfo::OnStartRequest(nsDocumentOpenInfo * const 0x03b24be8,
nsIRequest * 0x03b245d0, nsISupports * 0x00000000) line 219 + 16 bytes
nsStreamListenerTee::OnStartRequest(nsStreamListenerTee * const 0x03b91710,
nsIRequest * 0x03b245d0, nsISupports * 0x00000000) line 14
nsHttpChannel::ProcessNormal() line 444
nsHttpChannel::ProcessResponse() line 375 + 8 bytes
nsHttpChannel::OnStartRequest(nsHttpChannel * const 0x03b245d4, nsIRequest *
0x03b70e60, nsISupports * 0x00000000) line 2018 + 11 bytes
nsOnStartRequestEvent::HandleEvent() line 108 + 53 bytes
nsARequestObserverEvent::HandlePLEvent(PLEvent * 0x03b92174) line 64
PL_HandleEvent(PLEvent * 0x03b92174) line 590 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x0104bab8) line 520 + 9 bytes
_md_EventReceiverProc(HWND__ * 0x000702ae, unsigned int 49380, unsigned int 0,
long 17087160) line 1071 + 9 bytes
USER32! 77e148dc()
USER32! 77e14aa7()
USER32! 77e266fd()
nsAppShellService::Run(nsAppShellService * const 0x01104890) line 418
main1(int 1, char * * 0x00358208, nsISupports * 0x00000000) line 1128 + 32 bytes
main(int 1, char * * 0x00358208) line 1426 + 37 bytes
mainCRTStartup() line 338 + 17 bytes
KERNEL32! 77e992a6()
(Assignee)

Comment 1

17 years ago
this is a dupe of a bug assigned to bienvenu, and he has a fix in that bug..
anyone want to do some dupe searching? It's filed against "Mail database"
(Reporter)

Comment 2

17 years ago

*** This bug has been marked as a duplicate of 82590 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.