Full screen bug in telecinco.es

RESOLVED INVALID

Status

RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: fercarcedo, Unassigned)

Tracking

Trunk
x86_64
Windows 8

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:21.0) Gecko/20130218 Firefox/21.0
Build ID: 20130218031106

Steps to reproduce:

I visited this webpage http://www.telecinco.es/lanochedejosemota/programas-integros/noche-Jose-Mota-T01XP02_2_1557180189.html and, when I tried to set the video to fullscreen, its dimensions aren't fullscren, are half screen. This happens when I try to do this in the Windows 8 version of Firefox (it also happens in another websites, too), but it doesn't happen when I do the same in the desktop version of Firefox.


Actual results:

The video dimensions are half screen, and not fullscreen, as expected. I have to remark that this only happens on the new Windows 8 version, not on the traditional desktop version.


Expected results:

I don't know. Maybe it could be a Flash problem.
(Reporter)

Updated

6 years ago
Keywords: flashplayer
Blocks: 841214
Component: Untriaged → General
Product: Firefox → Firefox for Metro

Comment 1

6 years ago
This isn't flash, it's an HTML5 video stream (mp4).
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: flashplayer
OS: Windows 8 → Windows 8 Metro

Comment 2

6 years ago
..and it's broken on desktop as well with flash disabled.
Component: General → General
OS: Windows 8 Metro → Windows 8
Product: Firefox for Metro → Firefox
Version: 21 Branch → Trunk

Updated

6 years ago
Summary: Full screen bug in Firefox 21 Windows 8 version (Modern UI) → Full screen bug in Firefox 21 Windows 8
confirming with disabled flash and with Firefox trunk on windows7
works in Safari on OSX (without flash)
Component: General → Video/Audio
Product: Firefox → Core
Fullscreen doesn't seem to work at all in Metrofox.

For example, open http://pearce.org.nz/f in Metrofox, and note the text "Fullscreen API is either not present or disabled in your browser." at the top of the page.

Jim: for the fullscreen API to work in a document, every <iframe> element that encloses the document requesting fullscreen needs to have the "allowfullscreen" attribute present. Enclosing <browser> elements don't need to have an "allowfullscreen" attribute. Does the Metrofox chrome use <iframe> elements to display webpages, and if so do those <iframe>s have their "allowfullscreen" attribute present?
Component: Video/Audio → General
Product: Core → Firefox for Metro
Summary: Full screen bug in Firefox 21 Windows 8 → Full screen doesn't work in Metrofox; fullscreen API is not enabled
Summary: Full screen doesn't work in Metrofox; fullscreen API is not enabled → Fullscreen API doesn't work in Metrofox; it's not enabled

Comment 5

6 years ago
(In reply to Chris Pearce (:cpearce) from comment #4)
> Fullscreen doesn't seem to work at all in Metrofox.
> 
> For example, open http://pearce.org.nz/f in Metrofox, and note the text
> "Fullscreen API is either not present or disabled in your browser." at the
> top of the page.

That's bug 842130.

I was able to reproduce this bug on desktop by disabling flash. I just loaded the video and hit the fullscreen button in the overlay. The video expanded up to about half the size of browser window.

If you don't want this bug on desktop, we can dupe it to 842130.
Oops, this is indeed broken too on desktop, I failed to read the earlier comments.

This is a bug in the web page, it's not calling HTMLElement.mozRequestFullScreen(); I checked in my debugger.

You can still request fullscreen on the element with the right-click context menu, so fullscreen isn't broken in this case.

Resolving invalid.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
Summary: Fullscreen API doesn't work in Metrofox; it's not enabled → Full screen bug in telecinco.es
No longer blocks: 841214
You need to log in before you can comment on or make changes to this bug.