If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Extra space character after city name, before the comma, e.g. "Mountain View ,"

VERIFIED FIXED in 2013-02-21

Status

Participation Infrastructure
Phonebook
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: stephend, Assigned: sancus)

Tracking

({regression})

other
2013-02-21
regression

Details

(Whiteboard: [fromAutomation])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 716344 [details]
Screenshot on dev

test_profile_creation is failing now on dev, likely due to https://github.com/mozilla/mozillians/commit/ff1344b800a91c91d4245adf6f4e6b29ef9c6b68, from bug 763792 (though I have no proof, as of yet).

See http://qa-selenium.mv.mozilla.com:8080/view/Mozillians/job/mozillians.dev/2935/HTML_Report/?

STR:

1. Sign in and view https://mozillians-dev.allizom.org/en-US/u/masso32098

Here's why it's failing:

We set:

location.set_state('California')
location.set_city('Mountain View')

Yet, when we do our asserts, there's an extra space in here: "Mountain View ,"

That should be "Mountain View,"
(Assignee)

Comment 1

5 years ago
This'll be fixed by https://github.com/mozilla/mozillians/pull/404
Assignee: nobody → sancus

Comment 2

5 years ago
Commits pushed to master at https://github.com/mozilla/mozillians

https://github.com/mozilla/mozillians/commit/d93a6ee33fca43bc61c36dcd6d384fa55aa6486f
[Fix Bug 843458] Remove significant whitespace before some </a> tags

https://github.com/mozilla/mozillians/commit/f8037f134882efc3a86d136aac9b71aa1769f2c0
Merge pull request #404 from Sancus/bug843458

[Fix Bug 843458] Remove significant whitespace before some </a> tags

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2013-02-21
Duplicate of this bug: 843537
QA verified on dev and stage - thank you for the wicked quick patch!
mbrandt$ py.test --baseurl=http://mozillians-dev.allizom.org --credentials=/Users/mbrandt/Dropbox/workspaces/webqa-credentials/mozillians.yaml --destructive -ktest_profile_creation
== test session starts ==
platform darwin -- Python 2.7.2 -- pytest-2.2.4
collected 20 items 

tests/test_profile.py X
== 19 tests deselected by '-ktest_profile_creation' ==
== 19 deselected, 1 xpassed in 1.20 seconds ==
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.