Closed Bug 843468 Opened 7 years ago Closed 7 years ago

releases.mozilla.org is gone

Categories

(Infrastructure & Operations :: Infrastructure: Other, task, major)

x86_64
Linux
task
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: ToddAndMargo, Assigned: justdave)

Details

Attachments

(1 file)

656 bytes, text/plain
Details
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130212082553

Steps to reproduce:

My two frontier DNS servers (216.67.192.3, 74.40.37.242) do not resolve  releases.mozilla.org, but Google's (8.8.8.8) DNS's do.  Are you guys up to something?
http://www.frontierhelp.com/faq.cfm?qstid=143
says to use: 
    74.40.74.40
    74.40.74.41

and they don't work either
Shouldn't you rather report this to that ISP?

Resolving since I doubt this is a Mozilla Issue.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → INVALID
This seems to be a bigger issue, Mnyromyr and I also have this problem, so at least 3 ISPs fail to resolve the address, likely more.
Ok, confirmed over here too with ISP DTAG.

per http://isitup.org/releases.mozilla.org it with that Site's ISP.

RMO resolving to 202.177.202.154 works with my ISP per

  1     2 ms    <1 ms     1 ms  192.168.178.1
  2    22 ms    22 ms    23 ms  217.0.118.184
  3    23 ms    22 ms    24 ms  87.186.237.190
  4   126 ms   116 ms   119 ms  was-sb1-i.WAS.US.NET.DTAG.DE [62.154.5.186]
  5   120 ms   121 ms   120 ms  216.98.120.57
  6   188 ms   253 ms   216 ms  sjc002bb01.IIJ.net [206.132.169.150]
  7   307 ms   292 ms   302 ms  tky001bf01.IIJ.net [206.132.169.161]
  8   292 ms   299 ms   292 ms  tky001ip59.IIJ.Net [58.138.82.86]
  9   294 ms   293 ms   294 ms  210.130.154.38
 10   290 ms   289 ms   289 ms  pj-mirror01.mozilla.org [202.177.202.154]

RMO resolving to e.g. 156.56.247.196 does not work, neither Domain nor IP.
Assignee: nobody → server-ops
Status: RESOLVED → REOPENED
Component: Untriaged → Server Operations
Ever confirmed: true
Product: Firefox → mozilla.org
QA Contact: shyam
Resolution: INVALID → ---
Version: 19 Branch → other
dig a +trace releases.mozilla.org goes down until:

releases.mozilla.org.   60      IN      CNAME   releases.geo.mozilla.com.
;; Received 76 bytes from 63.245.212.5#53(63.245.212.5) in 21 ms

And releases.geo.mozilla.com is NXDOMAIN for all three Mozilla nameservers (63.245.212.5, 63.245.215.5, 63.245.218.7).
For anyone who is confused as to why they can't reproduce it, it's only on some Mozilla resolvers and which resolver you hit depends on your geolocation, so this only affects a certain segment of people.

It's not, however, an internal issue at specific ISPs as can be seen by the dig +trace results above.
I'm also seeing this with my isp.
Severity: normal → major
Assignee: server-ops → rwatson
Having this problem since yesterday.
Over to infra.
Component: Server Operations → Server Operations: Infrastructure
QA Contact: shyam → jdow
Assignee: rwatson → limed
geodns04 was dead.  I restarted mysql and named and it seems to have recovered.
Assignee: limed → justdave
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
(In reply to Dave Miller [:justdave] from comment #10)
> geodns04 was dead.  I restarted mysql and named and it seems to have
> recovered.

Also known as dp-geodns01, for anyone trying to figure that out in the future from this bug.
Attached file FTP log
I am still having trouble completing a connection to releases.mozilla.org via FTP.  I have attached the FTP log.
(In reply to David E. Ross from comment #12)
> Created attachment 724799 [details]
> FTP log
> 
> I am still having trouble completing a connection to releases.mozilla.org
> via FTP.  I have attached the FTP log.

I wanted to confirm this behaviour because it happened to me too.
But after aborting that connection and retrying it after ~10 Minutes it now works just fine.
-------------
Now it's NOT working again. The connection seems extremly slow and doesn't respond to aborts. "Here comes the directory listing" is the last thing I got back.
Is someone working on the FTP?
(In reply to David E. Ross from comment #12)
> Created attachment 724799 [details]
> FTP log
> 
> I am still having trouble completing a connection to releases.mozilla.org
> via FTP.  I have attached the FTP log.

Created Bug 851028
Duplicate of this bug: 850339
Component: Server Operations: Infrastructure → Infrastructure: Other
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.