Closed Bug 843475 Opened 8 years ago Closed 8 years ago

only one of the script with same name but diff. url is dispalyed in scripts list

Categories

(DevTools :: Debugger, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Optimizer, Unassigned)

References

Details

Maybe this will be fixed by bug 812083, but :

1) Go to http://grssam.com/test/test.html
2) Open debugger (Ctrl + Shift + S).
2) See how many scripts are laoded, only 1 will show up as js.php
3) See actual source code, there are 2 scripts.

Both of the scripts are actually loaded, its just the UI that does not show them both as they have the same name "js.php" while the full url is different (type=1 vs type=2)

To see that both scripts are loaded (or in other words, recognized by the dbg server) :
1) Stat the debugger and refresh the page.
2) The debugger will pause 2 times, one time at line 1 of js.php and other time on line 4 of js.php, while it will show the same file in both cases, one of the file does not even has 4 lines.
Depends on: 812083
One-source-instead-of-two-sources issue fixed by bug 812083.
Part of the behavior in comment #1 is (attempted) to be fixed in bug 785704.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
I am seeing one script as "js.php" and the other as "js.php?type=2" , is that expected ?

If yes, why is that the first one got the query string stripped, and not the other (and vice versa)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to Girish Sharma [:Optimizer] from comment #2)
> I am seeing one script as "js.php" and the other as "js.php?type=2" , is
> that expected ?
> 

Yes, it's by design.

> If yes, why is that the first one got the query string stripped, and not the
> other (and vice versa)

Because it's the first source that showed up.

The second source had to be distinguished somehow, and the request param seemed like the best choice, according to the algorithm: http://mxr.mozilla.org/mozilla-central/source/browser/devtools/debugger/debugger-panes.js#1117

File a new bug if you don't like it.
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.