pdf.js fails to render Ghostscript example shading pdf

VERIFIED FIXED in Firefox 29

Status

()

P3
normal
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: spider, Unassigned)

Tracking

18 Branch
Firefox 29
x86_64
Linux
Points:
---

Firefox Tracking Flags

(firefox29 verified, firefox30 verified, firefox31 verified)

Details

(Whiteboard: [pdfjs-c-rendering][pdfjs-d-shading-pattern][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/4192 [bugday-20140423])

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130206152940

Steps to reproduce:

I tried to load 
http://svn.ghostscript.com/ghostscript/tests/Ghent_V3.0/060_Shading_x1a.pdf

A and D fail on my PDF.js


Actual results:

I get pink boxes


Expected results:

Coloured boxes

Updated

6 years ago
Component: Untriaged → PDF Viewer

Updated

6 years ago
Priority: -- → P3
Whiteboard: [pdfjs-c-rendering][pdfjs-d-shading-pattern]

Comment 1

5 years ago
Same for me on XP with ff24, a & d are wrong.

There are two other examples here of shfill not working:
https://issues.apache.org/jira/secure/attachment/12610815/axial-input.pdf
https://issues.apache.org/jira/secure/attachment/12609129/input.pdf

Both are from this PDFBOX issue:
https://issues.apache.org/jira/browse/PDFBOX-615

If the Firefox pdf viewer can't do a shading operation, it should mention that the document "might not display correctly", as it is done with other "problem" pdfs (like the one that started this issue).

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Depends on: 965861
Resolution: --- → FIXED
Whiteboard: [pdfjs-c-rendering][pdfjs-d-shading-pattern] → [pdfjs-c-rendering][pdfjs-d-shading-pattern][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/4192
Target Milestone: --- → Firefox 29

Updated

5 years ago
QA Whiteboard: [good first verify]
Hi,

I was able to reproduce it on Mozilla/5.0 (X11; Linux x86_64; rv:21.0) Gecko/20130206 Firefox/21.0 ID:20130206031027 CSet: bc108d2ce8d1

I can confirm that the problem is no longer present in:

- latest Beta Mozilla/5.0 (X11; Linux x86_64; rv:29.0) Gecko/20100101 Firefox/29.0 ID:20140417185217 CSet: da279b9f523a

- latest Aurora Mozilla/5.0 (X11; Linux x86_64; rv:30.0) Gecko/20100101 Firefox/30.0 ID:20140423004003 CSet: 2d1b4d36eef9

- latest Nightly Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0 ID:20140423030202 CSet: ac376a4e8174
Status: RESOLVED → VERIFIED
QA Whiteboard: [good first verify]
status-firefox29: --- → verified
status-firefox30: --- → verified
status-firefox31: --- → verified
Whiteboard: [pdfjs-c-rendering][pdfjs-d-shading-pattern][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/4192 → [pdfjs-c-rendering][pdfjs-d-shading-pattern][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/4192 [bugday-20140423]
You need to log in before you can comment on or make changes to this bug.