tooltips aren't rounded when using oxygen-gtk2 gtk+ theme

RESOLVED DUPLICATE of bug 829425

Status

()

Core
Widget: Gtk
RESOLVED DUPLICATE of bug 829425
5 years ago
5 years ago

People

(Reporter: Hussam Al-Tayeb, Unassigned)

Tracking

19 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 716402 [details]
screenshot showing tooltip

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130221074236

Steps to reproduce:

tooltips aren't rounded when using oxygen-gtk2 gtk+ theme
Hussam, thanks for reporting this! 
Could you verrify if this is still valid with a newer Firefox version and in safe mode? We'd could verify if it's a theme problem.

https://support.mozilla.org/en-US/kb/troubleshoot-and-diagnose-firefox-problems?redirectlocale=en-US&redirectslug=Basic+Troubleshooting#w_3-restart-firefox-in-safe-mode
Flags: needinfo?(hussam)
(Reporter)

Comment 2

5 years ago
(In reply to Tiziana Sellitto [:tiziana] from comment #1)
> Hussam, thanks for reporting this! 
> Could you verrify if this is still valid with a newer Firefox version and in
> safe mode? We'd could verify if it's a theme problem.
> 
> https://support.mozilla.org/en-US/kb/troubleshoot-and-diagnose-firefox-
> problems?redirectlocale=en-US&redirectslug=Basic+Troubleshooting#w_3-restart-
> firefox-in-safe-mode

Yes, it still happens in newer builds. I tried 25alpha builds and also 24alpha builds.
Flags: needinfo?(hussam)
Component: Untriaged → Widget: Gtk
Product: Firefox → Core

Comment 3

5 years ago
(2012-06-18-03-05-31-mozilla-central-firefox-16.0a1.en-US.linux-x86_64 and earlier Nightlies crash for me with oxygen-gtk.

2012-06-20-06-51-38-mozilla-central-firefox-16.0a1.en-US.linux-x86_64 and newer do not.

That's probably related to bug 627699.)


Confirmed on Debian jessie/sid (testing) with Xfce.


Same with Iceweasel 17.0.8.

-- Package-specific info:

-- Extensions information
Name: Default theme
Location: /usr/lib/iceweasel/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
Package: iceweasel
Status: enabled

Name: English (GB) Language Pack locale
Location: /usr/lib/iceweasel/extensions/langpack-en-GB@iceweasel.mozilla.org.xpi
Package: iceweasel-l10n-en-gb
Status: enabled

-- Plugins information

-- Addons package information
ii  iceweasel      17.0.8esr-2  amd64        Web browser based on Firefox
ii  iceweasel-l10n 1:17.0.8esr- all          English (United Kingdom) language


Versions of packages iceweasel depends on:
ii  debianutils         4.4
ii  fontconfig          2.10.2-2
ii  libc6               2.17-7
ii  libgdk-pixbuf2.0-0  2.28.2-1
ii  libglib2.0-0        2.36.3-3
ii  libgtk2.0-0         2.24.20-1
ii  libnspr4            2:4.10-1
ii  libnspr4-0d         2:4.10-1
ii  libsqlite3-0        3.7.17-1
ii  libstdc++6          4.8.1-2
ii  procps              1:3.3.4-2
ii  xulrunner-17.0      17.0.8esr-2

iceweasel recommends no packages.

Versions of packages iceweasel suggests:
ii  fonts-stix [otf-stix]  1.1.0-1
ii  libgssapi-krb5-2       1.10.1+dfsg-6.1
pn  mozplugger             <none>

Versions of packages xulrunner-17.0 depends on:
ii  libasound2                1.0.27.1-2
ii  libatk1.0-0               2.8.0-2
ii  libbz2-1.0                1.0.6-4
ii  libc6                     2.17-7
ii  libcairo2                 1.12.14-4
ii  libdbus-1-3               1.6.12-1
ii  libdbus-glib-1-2          0.100.2-1
ii  libevent-2.0-5            2.0.21-stable-1
ii  libfontconfig1            2.10.2-2
ii  libfreetype6              2.4.9-1.1
ii  libgcc1                   1:4.8.1-2
ii  libgdk-pixbuf2.0-0        2.28.2-1
ii  libglib2.0-0              2.36.3-3
ii  libgtk2.0-0               2.24.20-1
ii  libhunspell-1.3-0         1.3.2-4
ii  libjpeg8                  8d-1
ii  libmozjs17d               17.0.8esr-2
ii  libnspr4                  2:4.10-1
ii  libnss3                   2:3.15-1
ii  libnss3-1d                2:3.15-1
ii  libpango-1.0-0            1.32.5-5+b1
ii  libpangocairo-1.0-0       1.32.5-5+b1
ii  libpangoft2-1.0-0         1.32.5-5+b1
ii  libpixman-1-0             0.26.0-4
ii  libsqlite3-0              3.7.17-1
ii  libstartup-notification0  0.12-3
ii  libstdc++6                4.8.1-2
ii  libvpx1                   1.2.0-2
ii  libx11-6                  2:1.6.0-1
ii  libxext6                  2:1.3.2-1
ii  libxrender1               1:0.9.8-1
ii  libxt6                    1:1.1.3-1+deb7u1
ii  zlib1g                    1:1.2.8.dfsg-1

Versions of packages xulrunner-17.0 suggests:
ii  libcanberra0  0.30-2
ii  libgnomeui-0  2.24.5-2

-- no debconf information

Comment 4

5 years ago
gtk2-engines-oxygen v1.3.3-2
Bug 829425 is tracking rounded tooltip work.
We need a crash stack or a link to a crash report to do anything about comment 3.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 829425

Comment 6

5 years ago
comment #3 is about old builds; there is no much information: 
bp-6563a3a0-717e-4dd8-a71d-ce2f72130814
bp-7c1b6ba7-b876-423c-9274-e56fe2130814
You need to log in before you can comment on or make changes to this bug.