pdf.js does not show numbers for some LaTeX documents

RESOLVED FIXED

Status

()

Firefox
PDF Viewer
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: zollern, Unassigned)

Tracking

19 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [pdfjs-c-rendering][pdfjs-d-font-conversion][pdfjs-d-hwa-off], URL)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130215130331

Steps to reproduce:

I opened ftp://ftp.rz.uni-wuerzburg.de/pub/tex/latex2e/contrib/numprint/numprint.pdf in Firefox 19.0.2. This also happens with some other documents compiled in LaTex.


Actual results:

Numbers throughout the program do not show up, e. g. in "version" on the title page.


Expected results:

All numbers are supposed to be displayed. The documentation above is for the LaTeX package numprint, I suspect that those numbers rendered by numprint itself are not shown. However, pdf.js ought to show the numbers.
(Reporter)

Updated

5 years ago
Component: Untriaged → PDF Viewer
FWIW, WFM using Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20130224 Firefox/22.0 ID:20130224031053 CSet: 195e706140d1 + PDF Viewer 0.7.256
Fixed in Nightly
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [pdfjs-c-rendering][pdfjs-d-font-conversion][pdfjs-d-hwa-off]
Mozilla/5.0 (Windows NT 6.1; rv:22.0) Gecko/20130312 Firefox/22.0, Build ID: 20130312031046
Not reproducible for me with the latest Nightly, but I couldn't reproduce on 19.0.2 either. 
Reporter, can you please confirm that your issue is fixed in the latest Nightly (http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/)?
Thank you!
Flags: needinfo?(zollern)
(Reporter)

Comment 4

5 years ago
The issue seems to be fixed as I cannot reproduce the bug on the latest Nightly. Thanks!
Flags: needinfo?(zollern)
You need to log in before you can comment on or make changes to this bug.