Wrong FPS in pages affected by opacity

VERIFIED FIXED

Status

Firefox OS
Gaia::Homescreen
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: crdlc, Assigned: crdlc)

Tracking

unspecified
x86
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:tef+, b2g18+ fixed, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
We can reach more fps in panning with some improvements about opacity
(Assignee)

Updated

5 years ago
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
(Assignee)

Comment 1

5 years ago
Created attachment 716461 [details]
Patch v1

This patch is based on the idea of a dedicated method for changing opacity carefully written to avoid as much as possible allocations and condition checks. Moreover we set the opacity with only one decimal. Thanks to those changes we achieve 8-10 fps more than before in pages affected by opacity transformations.
Attachment #716461 - Flags: review?(21)
Hey Christian why do I feel like I have already reviewed this code? Was it somewhere else in a different PR ? (Or maybe I forgot to click on a button?)
(Assignee)

Comment 3

5 years ago
jajaj, it is a Déjà Vu, you reviewed it as plus for other bug and we decided what it was useful but it didn't fix that bug. So, we talked about opening another separated bug. Then this one implements the correct opacity algorithm :) I thought that if I write + as review, it would be ugly :)
(Assignee)

Comment 5

5 years ago
https://github.com/mozilla-b2g/gaia/commit/ae6ca025c850ba9c49ea868b3aae905fe4315112
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

5 years ago
Comment on attachment 716461 [details]
Patch v1

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: lower FPS in landing page
Testing completed: yes
Risk to taking this patch (and alternatives if risky): low risk
String or UUID changes made by this patch:
Attachment #716461 - Flags: approval-gaia-v1?
status-b2g18: --- → affected
status-b2g18-v1.0.0: --- → wontfix
status-b2g18-v1.0.1: --- → wontfix
tracking-b2g18: --- → +
Comment on attachment 716461 [details]
Patch v1

Approving low risk fix for uplift.
Attachment #716461 - Flags: approval-gaia-v1? → approval-gaia-v1+
v1-train@c34e8b9
Requesting uplift to v1.0.1.  This is one of the patches in the MWC build so plenty of eyes on it.
blocking-b2g: --- → tef?
QA please take a look at this patch on v1-train and confirm that this does improve the experience.
Keywords: qawanted
QA Contact: jsmith
Going to find a new assignee to the verification.
QA Contact: jsmith

Updated

5 years ago
Keywords: qawanted → verifyme

Comment 12

5 years ago
Verified issue no longer repros.  

    Unagi Build ID: 20130225070200
    Kernel Date: Dec 5
    Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/3a5a27992a75
    Gaia: 5691a16fff8e1403c75ed9d6f3a443b7e58198c6
Status: RESOLVED → VERIFIED
Keywords: verifyme
QA Contact: jcouassi
I was not able to uplift this bug to v1-train.  If this bug has dependencies which are not marked in this bug, please comment on this bug.   If this bug depends on patches that aren't approved for v1-train, we need to re-evaluate the approval. Otherwise, if this is just a merge conflict, you might be able to resolve it with:

  git checkout v1-train
  git cherry-pick -x -m1 ae6ca025c850ba9c49ea868b3aae905fe4315112
  <RESOLVE MERGE CONFLICTS>
  git commit
(Assignee)

Comment 14

5 years ago
Hi John, this patch was merged by you two days ago:

https://github.com/mozilla-b2g/gaia/commit/c34e8b90c862c3086fbe11886ecafba8b6873ed2
Please go ahead with v1.0.1 uplift, I've marked status-b2g18 fixed as per comment 14
blocking-b2g: tef? → tef+
status-b2g18: affected → fixed
status-b2g18-v1.0.1: wontfix → affected
(In reply to crdlc from comment #14)
> Hi John, this patch was merged by you two days ago:
> 
> https://github.com/mozilla-b2g/gaia/commit/
> c34e8b90c862c3086fbe11886ecafba8b6873ed2

Ahh, the comments on the PR are for a different bug number.

v1.0.1: f5b94e4eda81f850a0b4a37817842f90b2b6d1da
status-b2g18-v1.0.1: affected → fixed
You need to log in before you can comment on or make changes to this bug.