Form select menu doesn't work when in a CSS translated container on Mac

RESOLVED DUPLICATE of bug 843675

Status

()

RESOLVED DUPLICATE of bug 843675
6 years ago
5 years ago

People

(Reporter: craig.morey, Unassigned)

Tracking

({testcase})

19 Branch
x86
Mac OS X
testcase
Points:
---

Firefox Tracking Flags

(firefox19- wontfix)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 716504 [details]
test.html

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_2) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.57 Safari/537.17

Steps to reproduce:

Form select menu is in a div that has the CSS "transform:translate(0px,0px)".

Running FF19 on OSX10.8.2 on Macbook Air 13" i7 and thunderbolt screen. All works fine in FF15 on same system. Test page attached.


Actual results:

When you click the select menu, the options open up, you can mouseover the select options, but can not select any of them. Clicking any option has no effect, the menu remains open.


Expected results:

Clicking on an option in a select menu should close the menu and show the newly selected option. The select menu being in a transformed container should have not effect.

Updated

6 years ago
Attachment #716504 - Attachment mime type: text/plain → text/html

Comment 1

6 years ago
All the 3 drop-down lists work normally with FF19 on Win 7. Maybe issue specific to OSX.
(Reporter)

Comment 2

6 years ago
Trying FF19 on Windows7, I can also confirm that the problem doesn't exist on the Windows build. 

We've tried on a few macs around here (mostly on 10.7/10.8) and all exhibit the apparent bug.
Component: Untriaged → Layout
Keywords: testcase
Product: Firefox → Core
This is fixed in 20, I believe...
Flags: needinfo?(tnikkel)
Summary: Form select menu doesn't work when in a CSS translated container → Form select menu doesn't work when in a CSS translated container on Mac
Whiteboard: DUPEME
Yes, this bug should be fixed in all versions except 19, sadly.

This is the second bug in a week since 19 has been released to be filed on this. I'll put  the tracking-firefox19: ? flag on this so release drivers can decide if they want to do anything about this.
Status: UNCONFIRMED → NEW
tracking-firefox19: --- → ?
Ever confirmed: true
Flags: needinfo?(tnikkel)
Bug 843675 was the other bug for reference.

Comment 6

6 years ago
Marking as wontfix for FF19 - this issue is Mac-specific and hasn't caused any critical web property regressions warranting a 19.0.1.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
status-firefox19: --- → wontfix
tracking-firefox19: ? → -
Resolution: --- → DUPLICATE
Duplicate of bug: 843675

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.