built-in PDF Viewer does not display a pdf

RESOLVED WORKSFORME

Status

()

P3
normal
RESOLVED WORKSFORME
6 years ago
3 years ago

People

(Reporter: itom_bo, Unassigned)

Tracking

19 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [pdfjs-c-rendering])

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130218103006

Steps to reproduce:

open this pdf file: http://www.leggotenerife.com/download/201302_leggotenerife_web.pdf



Actual results:

some pages appear with "black background"


Expected results:

display correct "white background"

Updated

6 years ago
Component: Untriaged → PDF Viewer
Seems to also happen on windows without hardware acceleration.  WFM on osx though.
Flags: needinfo?(itom_bo)
Priority: -- → P3
Whiteboard: [pdfjs-c-rendering]
(Reporter)

Comment 2

6 years ago
With Firefox 20.0 same "black background"
Flags: needinfo?(itom_bo)

Comment 3

5 years ago
nothing been done to rectify this.
I have had this problem and I have updated used plugins and it is a very necessary component of the internet. I like firefox but now I am going to need to start using something that works for pdf viewing. 
Fix it please

Comment 4

5 years ago
(In reply to meyersonpl from comment #3)
> nothing been done to rectify this.
> I have had this problem and I have updated used plugins and it is a very
> necessary component of the internet. I like firefox but now I am going to
> need to start using something that works for pdf viewing. 
> Fix it please

Provide a PDF file with such a behavior. Because I tried the PDF attached to this bug and it works with FF24 on Win 7 (HWA on/off), background is white as expected.

In addition, you're free to use a PDF plugin like Adobe Reader, Foxit or SumatraPDF on Windows.
Flags: needinfo?(meyersonpl)

Comment 5

4 years ago
Tommy, is it still an issue for you with FF37 or higher?
Flags: needinfo?(itom_bo)
(Reporter)

Comment 6

3 years ago
I'm late but with FF37 and higher the problem is solved. Thanks

Comment 7

3 years ago
Thank you.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(meyersonpl)
Flags: needinfo?(itom_bo)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.