JS error on setting up payments

RESOLVED WORKSFORME

Status

Marketplace
Developer Pages
P2
normal
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: Andy McKay, Assigned: scolville)

Tracking

2013-03-14
x86
Mac OS X
Points:
---

Details

(Whiteboard: p=, URL)

(Reporter)

Description

5 years ago
Traceback:

http://cl.ly/image/06153Q3U2u0r

On -dev I get: 

http://cl.ly/image/1M3747063K15

Which is presumably the same thing.

Comment 1

5 years ago
Can you reproduce this locally and if so, which file/where is the error happening?
Assignee: nobody → scolville
Priority: -- → P2
Whiteboard: p=
Target Milestone: --- → 2013-03-14

Comment 2

5 years ago
It looks like the error is because of that nasty HTML parse bug that we've been seeing because of the migration:

$('some html here') is no longer valid
$($.parseHTML('some html here')) is the way we need to go

Basically, if there's any whitespace or non-'<' characters at the head of the string, jQuery barfs.
Can't reproduce this in local env or at the url supplied.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.