PopupNotifications needs to know about location changes in background tabs

RESOLVED FIXED in seamonkey2.19

Status

SeaMonkey
General
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: neil@parkwaycc.co.uk, Assigned: neil@parkwaycc.co.uk)

Tracking

Trunk
seamonkey2.19

SeaMonkey Tracking Flags

(seamonkey2.18 fixed, seamonkey2.19 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Instead of using nsBrowserStatusHandler.js, we now need to notify PopupNotifications from each <notificationbox type="popup">.
(Assignee)

Updated

5 years ago
status-seamonkey2.18: --- → affected
(Assignee)

Comment 1

5 years ago
Created attachment 716756 [details] [diff] [review]
Possible patch

Unfortunately removing popupNotifications from nsBrowserStatusHandler.js means that I don't have anywhere convenient to remember whether I created the notifications lazily or not, so this version always creates the notifications eagerly, since they're going to be notified in the next location change anyway.

XBL isn't good at calling inherited methods so I moved as much as I could of the onLocationChange logic out to a separate method and duplicated the rest.
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #716756 - Flags: review?(iann_bugzilla)

Comment 2

5 years ago
From Bug 842412:

neil@parkwaycc.co.uk      2013-02-18 16:36:25 PST
> As per bug 839445 we need to notify the PopupNotifications object when any relevant
> onLocationChange fires, not just for the current tab.

[reply] [-] Comment 1 Philip Chee 2013-02-22 11:33:58 PST
> Neil pushed a wallpaper bustage fix (fallout from bug 839445).
> http://hg.mozilla.org/comm-central/rev/26093ce6e30c

Updated

5 years ago
Duplicate of this bug: 842412

Updated

5 years ago
Attachment #716756 - Flags: review?(iann_bugzilla) → review+
(Assignee)

Comment 4

5 years ago
Pushed comm-central changeset 97ec0b9859f1.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.19
(Assignee)

Comment 5

5 years ago
Comment on attachment 716756 [details] [diff] [review]
Possible patch

[Approval Request Comment]
Regression caused by (bug #): 839445
User impact if declined: PopupNotifications in background tabs linger
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): 
String changes made by this patch: None
Attachment #716756 - Flags: approval-comm-aurora?

Comment 6

5 years ago
Comment on attachment 716756 [details] [diff] [review]
Possible patch

a=me
Attachment #716756 - Flags: approval-comm-aurora? → approval-comm-aurora+
(Assignee)

Comment 7

5 years ago
Pushed comm-aurora changeset 76dc88ec42cf.
status-seamonkey2.18: affected → fixed
status-seamonkey2.19: --- → fixed
You need to log in before you can comment on or make changes to this bug.