[B2G][Everything.me] Everything.me appears to crash after exiting the Cheezburger site

VERIFIED DUPLICATE of bug 843204

Status

--
critical
VERIFIED DUPLICATE of bug 843204
6 years ago
6 years ago

People

(Reporter: ckreinbring, Unassigned)

Tracking

({crash, smoketest})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [b2g-crash])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 716819 [details]
Logcat logs

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130215130331

Steps to reproduce:

Unagi version: 20130221070203
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/effe37a77f18
Gaia: bb633c6f2deb829b2f3d5b9e7bac7fa24467d02a
Kernel: Dec 5

1. From the home screen, pan to Everything.me
2. Select Funny then Cheezburger.
3. Tap the Home key and observe the page that loads.
4. Pan back to Everything.me and observe its reaction.


Actual results:

Exiting the Cheezburger site returns the user to the home screen, but the screen is blank for a few seconds before the clock and the task bar icons appear.  Panning back to the Everything.me page shows the "Loading..." screen.


Expected results:

The user is returned to the Everything.me's Funny page.

Repro rate 3/4 devices
(Reporter)

Updated

6 years ago
Keywords: smoketest
OS: All → Gonk (Firefox OS)
Hardware: All → ARM
(Reporter)

Comment 1

6 years ago
Also seen in Funny > CollegeHumor, but the user has to navigate to another page first.
(Reporter)

Updated

6 years ago
Summary: Everything.me appears to crash after exiting the Cheezburger site → [B2G][Everything.me] Everything.me appears to crash after exiting the Cheezburger site

Updated

6 years ago
Severity: normal → critical
blocking-b2g: --- → shira?
Keywords: crash
Whiteboard: [b2g-crash]
not related to shira features. move to TEF?
blocking-b2g: shira? → tef?
(Reporter)

Comment 3

6 years ago
Also seen in Funny > Jokes com, but the user has to select a category then a joke first.
Another candidate for v1.0.1 blocklisting?
Flags: needinfo?(lmandel)
An UA override was added for icanhas.cheezburger.com in bug 843204. Please retest after the patch is uplifted.
Flags: needinfo?(lmandel)
(In reply to Lawrence Mandel [:lmandel] from comment #5)
> An UA override was added for icanhas.cheezburger.com in bug 843204. Please
> retest after the patch is uplifted.

QA, please verify the fix.
Keywords: qawanted, verifyme
QA Contact: jsmith
Reporter - Can you verify this is fixed?
Flags: needinfo?(ckreinbring)
Keywords: verifyme
QA Contact: jsmith
(Reporter)

Comment 8

6 years ago
It doesn't repro on the master build, but does on the current V1 train.

Master build version 20130226031044

V1 train version 20130226070204
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/819504e27351
Gaia: 823ae4703347ceb585f5d2de764d9d4138a6e892
Flags: needinfo?(ckreinbring)
(In reply to ckreinbring from comment #8)
> It doesn't repro on the master build, but does on the current V1 train.
> 
> Master build version 20130226031044
> 
> V1 train version 20130226070204
> Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/819504e27351
> Gaia: 823ae4703347ceb585f5d2de764d9d4138a6e892

Good. This is as expected as bug 843204 hasn't yet been uplifted.
Sounds like this will be resolved by bug 843024. Duping on that bug as such.
Status: NEW → RESOLVED
blocking-b2g: tef? → ---
Last Resolved: 6 years ago
Keywords: qawanted
Resolution: --- → DUPLICATE
Duplicate of bug: 843204
(Reporter)

Comment 11

6 years ago
In Unagi build 20130228070201, the Cheezburger site will still crash on exit if the user navigates to another Cheezburger page before exiting.  On the other hand, CollegeHumor and Jokes com (Comments 1 and 3) no longer repro crashing on exit.

Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/3867fca22e3d
Gaia: a41c7921fbf0839b894f277261dad4a22507f979
Kernel: Dec 5
(Reporter)

Comment 12

6 years ago
TheFancy Social Shopping, which is found in the Social folder, crashes out if the user loads an item's page.

Unagi build 20130307103636
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/a0b06192f882
Gaia: fa5245750e7bb94b9f64180967536509316dedf5
(In reply to ckreinbring from comment #12)
> TheFancy Social Shopping, which is found in the Social folder, crashes out
> if the user loads an item's page.
> 
> Unagi build 20130307103636
> Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/a0b06192f882
> Gaia: fa5245750e7bb94b9f64180967536509316dedf5

Instead of continuing to report these sites one by one in bugs, I suggest that a bug be opened for Everything.me content that crashes or otherwise breaks the phone. Everything.me can them make a decision about how to handle the broken content that is served via their integration.

Also, it is probably better to post new comments like this on the active bug instead of the bug marked as a dup in order for your comments to get more attention.

Comment 14

6 years ago
Verified as a Duplicate of 843204
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.