Last Comment Bug 844020 - Swiftkey keyboard and Firefox for Android hang when Firefox opens
: Swiftkey keyboard and Firefox for Android hang when Firefox opens
Status: RESOLVED FIXED
: hang
Product: Firefox for Android
Classification: Client Software
Component: Keyboards and IME (show other bugs)
: 19 Branch
: ARM Android
: -- critical with 1 vote (vote)
: Firefox 22
Assigned To: Kartikaya Gupta (email:kats@mozilla.com)
:
: Jim Chen [:jchen] [:darchons]
Mentors:
Depends on: 844275
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-22 02:20 PST by EddyCarr
Modified: 2016-07-29 14:32 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
affected
affected
affected
fixed


Attachments

Description EddyCarr 2013-02-22 02:20:28 PST
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130215130331

Steps to reproduce:

I open firefox for android and as soon as it has come up I click into the awesome bar to search. My swiftkey keyboard opens as it should and I begin typing my search. 


Actual results:

However on the 1st of 2nd letter the keyboard freezes and stops taking input. Firefox also freezes and stops taking input. The whole phone screen remains frozen (except I can open and close the notifications bar) however long I wait.

I then have to click the Home button to get back to the home screen. Often even then the keyboard doesn't close but remains on the top of the screen, frozen. I then have to manually force close Firefox and the keyboard disappears. 


Expected results:

Keyboard should input letters into the awesome bar and then should disappear when I click Return key or Search button.
Comment 1 EddyCarr 2013-02-22 02:22:52 PST
I should say that this happens only 40-50% of the time when I start Firefox. I cannot be sure but my impression is that it tends to happen when returning to an open session of Firefox after viewing another app. When opening Firefox from scratch it doesn't happen so often.
Comment 2 Aaron Train [:aaronmt] 2013-02-22 09:30:51 PST
Do you happen to see these problems on Aurora (http://aurora.mozilla.org) or Nightly (http://nightly.mozilla.org) for Android?
Comment 3 Kartikaya Gupta (email:kats@mozilla.com) 2013-02-22 14:28:41 PST
From the sounds of it this is almost certainly related to the compositor startup mess that I'm trying to fix in bug 844275. Specifically I think opening the awesomescreen right on startup blocks all the threads and then typing causes an ANR. I should have a test build soon that you can try to verify if my patches fix this problem.
Comment 4 EddyCarr 2013-02-25 03:23:59 PST
@Aaron Train - Yes I can replicate the issue on Aurora. Not tested yet on nightly. I'll test today.

@Kartikaya Gupta - It sounds like that might be the issue. In that case the SwiftKey keyboard might just be a distraction. Let me know if there is anything I can do to confirm that it is the same issue.
Comment 5 Kartikaya Gupta (email:kats@mozilla.com) 2013-02-25 09:52:53 PST
There is an APK in the folder at http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/kgupta@mozilla.com-829b88f0a037/try-android/ which you can install and try out. The changes in that build don't pass all of our tests yet so I'll probably need to tweak it some more, but I think it should solve the problem for you. Please give it a whirl and see if you still run into the same problem. The APK will install as the "Nightly" app on your phone, and will use a different profile from any existing Firefox apps you have installed, so you can uninstall it when you're done without impacting any of your existing data.

If you're still able to reproduce the problem with that build I can send you another build with more logging to try and figure out what's going on.
Comment 6 EddyCarr 2013-02-25 09:59:17 PST
Is it 'fennec-22.0a1.en-US.android-arm.apk'?
Comment 7 Kartikaya Gupta (email:kats@mozilla.com) 2013-02-25 10:04:03 PST
Yes.
Comment 8 EddyCarr 2013-02-26 02:34:46 PST
I tested this quite a bit yesterday and cannot replicate the issue. It seems to be fixed.

I'm now using this build as my primary browser so I'll keep testing and let you know if I manage to replicate the issue.
Comment 9 Kartikaya Gupta (email:kats@mozilla.com) 2013-02-26 06:03:58 PST
That's great news, thanks!
Comment 10 EddyCarr 2013-02-27 09:36:07 PST
I've been using the new build all day today. No problems. I'm pretty confident that the issue is totally fixed.

Great job!

Hopefully we can get this onto aurora soon?
Comment 11 Kartikaya Gupta (email:kats@mozilla.com) 2013-02-27 10:32:39 PST
Hopefully. I'm still trying to figure out why some of the tests are failing :(
Comment 12 EddyCarr 2013-02-28 09:28:46 PST
Ok good luck! Let me know if there is anything I can do to help (unfortunately I'm not a developer though).
Comment 13 Kartikaya Gupta (email:kats@mozilla.com) 2013-02-28 10:38:46 PST
Thanks :) I was able to figure out the problems and landed the patches on our inbound tree today. Assuming it doesn't get backed out, it'll probably be in tomorrow's nightly (or the day after if it misses the merge). I'll post here again once the changes get merged to m-c so you know which build it'll be in and can pick that up if you want.
Comment 14 EddyCarr 2013-03-01 02:23:45 PST
Amazing, thanks a lot.
Comment 15 Kartikaya Gupta (email:kats@mozilla.com) 2013-03-01 07:02:37 PST
This should be fixed in the March 1 nightly with the landing of bug 844275. Closing this bug based on Eddy's previous testing, since the patches that landed were very close to the ones he tested earlier. Please feel free to reopen this bug if the issue persists. Once this has spent a few days on the nightly channel with no regressions I will request it be uplifted to aurora as well. If you're interested in following along I would suggest CCing yourself onto bug 844275.
Comment 16 veganUP 2013-04-23 15:05:30 PDT
I have exactly the same issue. I'm not terribly technical, so for the layman, does "resolved" mean this will be remedied in a future ff release, or a workaround as described above is required for users experiencing this issue?
 Thanks in advance.
Comment 17 EddyCarr 2013-04-23 15:15:45 PDT
Hi veganUP,

The bug has been fixed in firefox 22 (currently in Aurora). When firefox 22 reaches stable (around 25th of June 2013) it will be totally sorted. Until then the best option for me is to use Aurora. You can download from here:

https://www.mozilla.org/en-US/mobile/aurora/

You might choose to move to Firefox Beta when version 22 reaches the beta stage, some time after the 14th of May.

Hope that helps.

Note You need to log in before you can comment on or make changes to this bug.