If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

localized firefox nightlies do full updates only, update.status does not exist

RESOLVED DUPLICATE of bug 843073

Status

()

Toolkit
Application Update
RESOLVED DUPLICATE of bug 843073
5 years ago
5 years ago

People

(Reporter: Pike, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
I get this in my console for nightly updates right now:

*** AUS:SVC Creating Downloader
*** AUS:SVC UpdateService:_downloadUpdate
*** AUS:SVC readStringFromFile - file doesn't exist: /Applications/FirefoxNightly.app/Contents/MacOS/updates/0/update.status
*** AUS:SVC readStatusFile - status: null, path: /Applications/FirefoxNightly.app/Contents/MacOS/updates/0/update.status
*** AUS:SVC Downloader:downloadUpdate - downloading from http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013/02/2013-02-22-03-11-33-mozilla-central-l10n/firefox-22.0a1.de.mac.complete.mar to /Applications/FirefoxNightly.app/Contents/MacOS/updates/0/update.mar


After the update, I see


wokbok:~ axelhecht$ *** AUS:SVC Creating UpdateService
*** AUS:SVC gCanCheckForUpdates - able to check for updates
*** AUS:SVC gCanApplyUpdates - testing write access /Applications/FirefoxNightly.app/Contents/MacOS/update.test
*** AUS:SVC gCanApplyUpdates - able to apply updates
*** AUS:SVC readStatusFile - status: succeeded, path: /Applications/FirefoxNightly.app/Contents/MacOS/updates/0/update.status
*** AUS:SVC readStatusFile - status: succeeded, path: /Applications/FirefoxNightly.app/Contents/MacOS/updates/0/update.status
*** AUS:SVC cleanUpMozUpdaterDirs - Cleaning MozUpdater folder
*** UTM:SVC TimerManager:registerTimer - id: browser-cleanup-thumbnails

/Applications/FirefoxNightly.app/Contents/MacOS/updates/0 exists, and is empty. Which is also true on the release channel.

No idea where the culprit is, nor if it's l10n specific.
(Reporter)

Comment 1

5 years ago
Note, my update url was https://aus3.mozilla.org/update/3/Firefox/22.0a1/20130221072044/Darwin_x86_64-gcc3-u-i386-x86_64/de/nightly/Darwin%2011.4.2/default/default/update.xml, which only shows a full update. Maybe releng? Or too many nightlies a day?
We're only serving complete updates right now because of bug 841094. We'll be serving partials again starting Tuesday. This is tracked in bug 843073.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 843073
You need to log in before you can comment on or make changes to this bug.