regxpcom.exe goes into "infinite loop" behavior on Beatnik component registration

VERIFIED FIXED in mozilla0.9.3

Status

()

P2
normal
VERIFIED FIXED
18 years ago
11 years ago

People

(Reporter: arun, Assigned: peterlubczynski-bugs)

Tracking

({regression})

Trunk
mozilla0.9.3
x86
Windows 98
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: pdt+ ; [baking in trunk], URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Testing using Win98 running 2001060509
1. Obtain the Beatnik plugin.
2. The VISE installer will download.
3. If running Mozilla, run regxpcom.exe manually after dropping the dll and xpt
in the components directory.  Note that on Netscape 6.01, which the installer
recognizes, regxpcom.exe is invoked automagically for you.  On Mozilla, you have
to try manually.
4. Notice the "infinite loop" behavior which you can kill using CTRL-C (the DOS
window will close).

Expected Behavior: smooth component registration as on 0.6 (and thus, Netscape
6.01).
Actual Behavior: The message "Component registration successful" keeps scrolling
by without stopping.  Infinite loop type behavior.

Comment 1

18 years ago
Created attachment 37960 [details] [diff] [review]
patch: proposed fix

Comment 2

18 years ago
Attached fix for ProcessArgs in regxpcom.cpp.  It never stopped processing the 
current argument if it was not preceded by a '-'.

Comment 3

18 years ago
reassigning to Mike since he last touched regxpcom.cpp.

Mike, can you please review the attached patch that fixes an infinite loop in 
regxpcom?
Assignee: rayw → shaver
Keywords: regression, review

Comment 4

18 years ago
*** Bug 85696 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Keywords: mozilla0.9.2
Wow, I'm a loser.

r/sr=shaver.
Status: NEW → ASSIGNED

Comment 6

18 years ago
Thanks Mike.

Checked into trunk -->
Checking in regxpcom.cpp;
/cvsroot/mozilla/xpcom/tools/registry/regxpcom.cpp,v  <--  regxpcom.cpp
new revision: 1.14; previous revision: 1.13
done

marking fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 7

18 years ago
I think we need this on the 0.9.2 branch, right?
who can we line up to move the patch over if its not there.
Whiteboard: pdt+ ; need to move patch to branch

Comment 8

18 years ago
I'm going to reopen so it shows up as a task to do on the branch.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 9

18 years ago
Does checkin to the branch require anything special to a cvs account?  Or is 
access simply limited to approval?  If so, I should be able to get the patch on 
the branch.  I sent mail to drivers last night for 0.9.2 consideration but 
haven't received a response yet.  
(Reporter)

Comment 10

18 years ago
peterl, since there's no longer a pesky a= requirement, could you check this in
on sean's behalf?  the branch is accepting important pdt+ nominated checkins.
(Assignee)

Comment 11

18 years ago
re-assign to myself for banch checkin later today.
Assignee: shaver → peterlubczynski
Status: REOPENED → NEW
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Priority: -- → P2
Whiteboard: pdt+ ; need to move patch to branch → pdt+ ; [baking in trunk]
Target Milestone: --- → mozilla0.9.3
(Assignee)

Comment 12

18 years ago
Patch in BRANCH, marking FIXED.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Updated

18 years ago
QA Contact: rayw → shrir

Comment 13

18 years ago
marking verif.(stampd)
Status: RESOLVED → VERIFIED

Updated

11 years ago
Component: XPCOM Registry → XPCOM
QA Contact: shrir → xpcom
You need to log in before you can comment on or make changes to this bug.