After upgrade, old Metro splash screen still appears instead of new one

RESOLVED INCOMPLETE

Status

Firefox for Metro
Shell
--
minor
RESOLVED INCOMPLETE
5 years ago
5 months ago

People

(Reporter: mbrubeck, Unassigned)

Tracking

Trunk
All
Windows 8.1
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [defect] p=0)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
After upgrading from an older nightly build to the 2013-02-22 mozilla-central nightly, I still see the old "Mozilla Firefox" splash screen instead of the new "Nightly" one added in changeset 201b64ad48d8 (bug 735008).

This is probably not very high-proirity, since it only impacts users who install and run Metro Firefox, then upgrade to a new version that uses a different splash screen.  Jim notes on IRC, "Not sure if we want to refresh the splash image on every update. Suppose we could. Probably hits startup perf a bit on the first run after an update."

Comment 1

5 years ago
Created attachment 717328 [details] [diff] [review]
fix
Assignee: nobody → jmathies
Attachment #717328 - Flags: review?(netzen)
Attachment #717328 - Flags: review?(netzen) → review+
did you test this with running <installdir>/uninstall/helper.exe /PostUpdate from a command prompt btw?

Comment 3

5 years ago
(In reply to Brian R. Bondy [:bbondy] from comment #2)
> did you test this with running <installdir>/uninstall/helper.exe /PostUpdate
> from a command prompt btw?

Sort of. To do this I needed a full install with an uninstall log. So I installed an mc nightly, then copied over a new helper.exe and tried it with the new manifest in bug 844270. I got the new splash screen background but for some reason my tile image got screwed up.

Comment 4

5 years ago
Comment on attachment 717328 [details] [diff] [review]
fix

don't think this should land. without going through the process of setting the browser as the default, the tile gets screwed up. Maybe deleting just the image sub keys will work.
Attachment #717328 - Flags: review+ → review-

Comment 5

5 years ago
Pave over installs of the default browser don't seem to have a problem though.

Comment 6

5 years ago
This info doesn't get refreshed if we only delete data from this key and launch. I'm not sure what pave overs do differently but they do manage to trigger a refresh.

Comment 7

5 years ago
Thinking about Metro Firefox as a shipping product, if we decide to update our shipping splash screen, would this bug prevent our users from seeing the new splash screen?

Updated

5 years ago
Assignee: jmathies → nobody

Updated

4 years ago
Blocks: 935467

Updated

4 years ago
Blocks: 861680
No longer blocks: 935467, 735008
Whiteboard: [defect] p=0
(In reply to Asa Dotzler [:asa] from comment #7)
> Thinking about Metro Firefox as a shipping product, if we decide to update
> our shipping splash screen, would this bug prevent our users from seeing the
> new splash screen?

I believe the answer is "yes, at least until Windows refreshes its cache (maybe at reboot?)"

Brian - does that seem accurate?
Flags: needinfo?(netzen)
Yep, likely people will see the old splash screen, but I'm not sure under which conditions. We can ask QA to help us out on the conditions if we anticipate a need to update the splash screen.
Flags: needinfo?(netzen)

Comment 10

4 years ago
A full pave over should fix this, we added some registry cleanup in bug 796887 for this. We tried the same on updates here but it ended up screwing up the tile image for some reason.

If someone wants to revisit this feel free.

Updated

4 years ago
Depends on: 969595
(Assignee)

Updated

4 years ago
OS: Windows 8 Metro → Windows 8.1
Mass close of bugs in obsolete product https://bugzilla.mozilla.org/show_bug.cgi?id=1350354
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.