Closed Bug 844260 Opened 8 years ago Closed 8 years ago

New in private windows restores tabs

Categories

(Firefox :: Private Browsing, defect)

20 Branch
x86_64
Windows 8
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 829568

People

(Reporter: u416532, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130220104816

Steps to reproduce:

Set "show windows and tabs from last time" in options.  Opened some tabs.  Closed firefox.  right clicked on Firefox icon on the taskbar.  Clicked new private windows.
Closed firefox.  Open firefox normally.


Actual results:

Firefox restored my tabs in the in private window.  Firefox did not restore my tabs when I started Firefox normally.  Firefox open a random tab I had closed several days ago.
I think it's a new regression in FF20, I read another reports about this issue.
Fixed window(m-c)
Bad:
http://hg.mozilla.org/mozilla-central/rev/e8f8a3f6f1f6
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20130218 Firefox/21.0 ID:20130218212328
Fixed
http://hg.mozilla.org/mozilla-central/rev/3f0f2fc4bd0f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20130219 Firefox/21.0 ID:20130219014027
Fixed pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e8f8a3f6f1f6&tochange=3f0f2fc4bd0f

I guess Bug 829568 fixes the problem
Blocks: 818732
Component: Untriaged → Private Browsing
Depends on: 829568
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 829568
You need to log in before you can comment on or make changes to this bug.