Closed Bug 844265 Opened 7 years ago Closed 5 years ago

XML Parsing Error: unexpected parser state // Syntax error in Firefox: connectionFailure // netError.xhtml

Categories

(Firefox :: Untriaged, defect)

19 Branch
x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 569229

People

(Reporter: m021, Unassigned)

Details

Attachments

(2 files)

Attached image temp.png
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130215130331

Steps to reproduce:

I browsed to site http://www.network54.com/Forum/254541/, which was down at the time.


Actual results:

I saw the following error message in a box with a narrow dark border:

XML Parsing Error: unexpected parser state
Location: jar:file:///C:/Program%20Files/Mozilla%20Firefox/omni.ja!/chrome/toolkit/content/global/netError.xhtml
Line Number 304, Column 68:

<div id="ed_connectionFailure">&connectionFailure.longDesc;</div>



Expected results:

I should have received a human-readable error message reporting that the site could not be reached, and perhaps the problem that was encountered.
Might be related: bug 844831, bug 802725.
Summary: Syntax error in Firefox: connectionFailure → XML Parsing Error: unexpected parser state // Syntax error in Firefox: connectionFailure // netError.xhtml
Sporadically getting the same error the last 2 or 3 days.

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Attached image bug1.png
also happens on Windows 8.0 Firefox version 25.0.1
Comment on attachment 8340354 [details]
bug1.png

Reproducibility procedure
1. Network was disconnected from internet (note: network is enabled but no internet connection)
2. Visit facebook.com


Expected Result
1. Message saying that connection timed out or something (error page displayed)

Actual Result
2. XML trace of error displayed.
Also received at http://physrev.physiology.org/cgi/doi/10.1152/physrev.00014.2003, Firefox release 29.0.1. Win XP x86 SP3.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 569229
You need to log in before you can comment on or make changes to this bug.