picking view->use stylesheet crashes everytime

VERIFIED WORKSFORME

Status

()

Core
XUL
VERIFIED WORKSFORME
17 years ago
10 years ago

People

(Reporter: Michael J Estes, Assigned: Marc Attinasi)

Tracking

Trunk
x86
FreeBSD
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; FreeBSD 4.3-STABLE i386; en-US; rv:0.9.1+)
Gecko/20010605
BuildID:    2001060618

picking a different style sheet or none will crash mozilla every time

Reproducible: Always
Steps to Reproduce:
1.visit http://www.w3.org/Style/CSS/
2.click view->use stylesheet and pick none or one of the many styles
3.cry cause mozilla crashed

Actual Results:  crash, no error messages in command line

Expected Results:  change stylesheet

This used to work months ago.  I can't remember when this specifically changed.
 haven't tested on any other OS
(Reporter)

Comment 1

17 years ago
Created attachment 37478 [details]
html testcase that shows crash, try switching stylesheet to none
(Reporter)

Comment 2

17 years ago
Created attachment 37479 [details]
css file for testcase

Comment 3

17 years ago
I can't reproduce the crash in 06/05 trunk builds on mac/linux/win2k. The 
stylesheets are applied to the document with no problem (on linux and win2k).
On Mac, this UI is either broken, or never worked (was implemented in bug 6782
in 09/2000) -- I'll file a bug on the Mac UI issue.

But for the crash reported here, can anyone get either a stack trace or a 
Talkback ID for this crash. It would help in narrowing it down. 

This is more likely to be a crash in Layout/Style System, then a crash on 
the menu itself, so -> attinasi, Style System for now. 
Assignee: pinkerton → attinasi
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: jrgm → ian
(Reporter)

Comment 4

17 years ago
Ok, my debug build finished and tada... style changes as it should.  I guess
this is just a "personal problem" as i build with -O3 and that is likely the
cause of this.  

-O3 is generally very stable for me except for a few quirks like this.  like if
I click on the maximize button in sawfish before the chrome has finished
loading.. crash every time.

so basically unless you want a bug on -O3 optimization issues then this can be
marked WFM or invalid.  sorry for overlooking this in the first place
(Assignee)

Comment 5

17 years ago
WFM
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 6

17 years ago
verified. 

(As for '-O3' bugs, it would be a long time before anyone started looking into 
it, by which time, both the mozilla codebase and the compiler codebase would 
have changed enough that that bug would probably have become WFM too :-]).
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: ian → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.