"Assertion failure: gl->IsFramebufferComplete(fb)"

RESOLVED WORKSFORME

Status

()

defect
--
critical
RESOLVED WORKSFORME
7 years ago
2 years ago

People

(Reporter: jruderman, Unassigned)

Tracking

(Blocks 1 bug, {assertion, regression, testcase})

Trunk
x86_64
macOS
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted] webgl-internal)

Attachments

(2 attachments)

Assertion failure: gl->IsFramebufferComplete(fb), at gfx/gl/GLScreenBuffer.cpp:560

I'm guessing this is a regression from bug 716859.
Posted file stack
Component: SVG → Canvas: WebGL
Ok, this looks simple enough. It looks like we aren't handling too-large canvases properly.
Whiteboard: webgl-internal
Is this bug still valid?
Flags: needinfo?(jruderman)
Whiteboard: webgl-internal → [gfx-noted] webgl-internal
On Win7 debug, this intermittently hits [@ mozilla::gl::GLContext::AfterGLCall(char const *)] crashes on Try that look a lot like bug 1402553 (known OOM-like behavior). Otherwise, it looks green.
https://treeherder.mozilla.org/logviewer.html#?job_id=142941461&repo=try

I'm inclined to just mark this WFM and land the test skipped on Win7 debug.
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(jruderman) → in-testsuite+
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.