'View->Use Stylesheet' provides no alternatives on Mac menus

VERIFIED WORKSFORME

Status

()

VERIFIED WORKSFORME
18 years ago
10 years ago

People

(Reporter: jrgmorrison, Assigned: mikepinkerton)

Tracking

Trunk
PowerPC
Mac System 9.x
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
The native menus on Mac don't seem to generate the list of alternative 
stylesheets (ones that are defined as available in the content of the page).

Steps to reproduce:
1) go to http://www.w3.org/Style/CSS/
2) open the 'View->Use Stylesheet' submenu

Actual Results: one option available, 'none', on the Mac
Expected Results: on win32 and Linux, 8 or 9 alternatives are named. 

This UI was originally implemented on bug 6782, primarily in patch 
http://bugzilla.mozilla.org/showattachment.cgi?attach_id=11225

I'm assuming this is related to the Mac menu implementation, since it works
with the non-native menus on win32 and Linux.

(See also bug 84428 for a related crash, reported on BSD).
(Assignee)

Comment 1

18 years ago
with my opt trunk build from 6/4 this works fine. jrgm, what build are you
using? And if you're using a current one, something in gecko must have changed
because no menu code is different.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

18 years ago
Um, strange. This works now. I think that the problem was that the stylesheets
were not loaded from the network earlier, and so not displayed. [Although, it
seems unfortunate that alternates must be physically fetched in order to be 
offered, but that's another story]. Sorry for the bad bug.
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.