pdf.js makes pdf unreadable for some documents (not enough zoom maybe) and other feedback

RESOLVED DUPLICATE of bug 827496

Status

()

Firefox
PDF Viewer
RESOLVED DUPLICATE of bug 827496
5 years ago
5 years ago

People

(Reporter: Marius Hudea, Unassigned)

Tracking

19 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 717426 [details]
3005X-III_schematic.pdf - datasheet that is unreadable at 400% and visual artefacts from zoom perhaps

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130215130331

Steps to reproduce:

Apologies if this is already known, I see 81 bug reports and don't have time to check each one.

had a power failure and after restart, Firefox auto updated and replaced adobe acrobat viewer with the internal pdf viewer.. WITHOUT NOTIFICATION of any kind, which I don't think it's nice. 


Actual results:


Anyway, opened a pdf with a circuit schematic (a datasheet for a device) that was working just fine in acrobat plugin viewer but pdf.js has problems with it:

* by default the whole pdf is very small, maybe 10% the normal view I'd have in acrobat viewer or Sumatra pdf viewer. 
* even zoomed at 400% the document is unreadable - the lines and component drawings have aliasing issues, most of the text is unreadable.
* zoom is horrible, every time I click on zoom the document resets to top left corner, it's impossible to zoom a certain area of the document (keep a part of page centered or something, I don't know how to explain)
* scrolling is horrible and slow, everything is redrawn at each scroll movement and it's laggy even on my Athlon FX-8320, an eight core processor. I can't imagine how it would work with slower processors.



Expected results:

The pdf should have opened in the old acrobat plugin that I have configured before. Or at least let me know on screen that there's a new internal functionality and ask me if I want to try it out. 
Had to google to find out that I have to go to Options > Applications to reselect Acrobat plugin

As for document itself, it should be rendered correctly, with letters and numbers visible at 400% - they are readable, just barely, in Sumatra PDF reader, at 400%. At 800%, the document is very readable. 
The zoom is also somewhat incorrect, maybe it's some compression of the rendering that makes lines and triangles in the datasheet gray or blurry? 

The whole page re-renders in an ugly way even if I scroll down a few pixels. 

I will attach the datasheet, along with a couple of screen captures to show how the document is rendered on my computer in pdf.js , sumatra pdf , adobe acrobat plugin 

Notice the Adobe Acrobat plugin actually renders some letters and numbers bolded and possibly with another font, while Sumatra pdf and the internal pdf viewer uses the same font.
(Reporter)

Comment 1

5 years ago
Created attachment 717427 [details]
Screen captures of rendering in internal pdf viewer and 2 other viewers

pdf_js_screencapture.png - how the datasheet looks at 400% zoom in pdf.js
adobe_plugin_zoom400.png - how adobe plugin renders the document at 400%
sumatra_pdf_zoom400.png - how sumatra pdf viewers renders the document at 400%
sumatra_pdf_zoom600.png - sumatra at 600%, perfectly readable.
(Reporter)

Updated

5 years ago
Component: Untriaged → PDF Viewer

Comment 2

5 years ago
Please take a look at the PDF file " English (5 MB) " in the " http://www.sonymobile.com/global-zh/support/phones/xperia-neo-l/support-documents/ " and check to see why the content is not correctly displayed. This PDF file is well displayed on Chrome. Thanks.
There are too many issues in one here, please file separate issues.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

5 years ago
You know what, how about you just pick a random one out of the ones I wrote and attempt to fix it, instead of marking everything as invalid? 
You have my full permission to do that.

Based on my previous experience with posting bugs in this system, whatever you choose is probably not going to be fixed in 2 years or by the time someone looks at it, the functionality will be removed or obsoleted.

If you don't believe me, look at bug 378184 which I submitted in 2007.

If you think every person submitting bugs is going to waste his time resubmitting said bugs just because you don't like how the bug was submitted, you're delusional.
Hi Marius,
The pdf.js teams is very small and having smaller/one part/actionable bugs makes it easier for us to prioritize common issues and it also makes it easier to go back and read bugs when they don't have 10 different parts in one.
(Reporter)

Comment 6

5 years ago
There are THREE issues reported in this bug report:

1. PDF documents that need at least 400% zoom to be viewed will be almost unreadable due to blurriness

2. Scrolling at such zoom levels in painfully slow and redrawing is performed too often/ugly

3. When zoom level is changed, position on page is lost, you're moved to top left corner of document or page. 

As much as I understand that lots of bugs are submitted and some developer teams are small, I personally lost the motivation to report posts and waste time doing it, when there's a high chance they get the equivalent of being thrown in the trash due to technicalities, or completely ignored. 

Feel free to copy/paste and create three bug reports referring to this bug report. I'm not going to do it.
First half of the comment 6 looks as a valid bug report. I think we can mark it as a duplicate of bug 827496.
Resolution: INVALID → DUPLICATE
Duplicate of bug: 827496
(Reporter)

Comment 8

5 years ago
It's not quite the same as that bug. 

That bug report only addresses the fact that the zoom options are not enough. For example, making pdf documents zoom to 1000% won't fix the issues in this bug.

Please check the screen captures I've attached to this post. 

pdf.js zooms to 400% but compared to other pdf viewers, it does not maintain correct proportion between drawings and fonts in the document, as other pdf viewers do. 

Some fonts remain very small, just a few pixels tall, unreadable - at 400% zoom the other viewers render the font at large enough size to be readable.  

The lines in the drawing are blurry, maybe it's the resizing/rescaling algorithm used, or too much anti-aliasing or whatever it's called.. the straight lines are are made out of thicker gray lines instead of thin dark black lines.

But all this is pointless if every time you zoom your view goes to top left corner of the page... it's no fun to scroll in both directions to find a place in a A0 document after zooming to 400% - can't imagine how it would be at 1000%.
You need to log in before you can comment on or make changes to this bug.