bookmarkable template should not include empty/unset default variables

RESOLVED DUPLICATE of bug 594928

Status

()

Bugzilla
User Interface
--
enhancement
RESOLVED DUPLICATE of bug 594928
5 years ago
5 years ago

People

(Reporter: tomer, Unassigned)

Tracking

Details

(Reporter)

Description

5 years ago
I find the bookmarkable template pretty useful, as it allow me to supply others a link to the bug entering form when the right product/component already selected, and at the same time inject other useful information into the form, such as adding myself to the CC list. 

Every time I use the feature by pressing the "Remember values as bookmarkable template" I have to paste the link content into a text editor, and remove every unnecessary field. This procedure helps make the link way shorter are more suitable to email messages as well as IM. I'd like if this process could be happened automatically so the served link won't include these fields. 

i.e.,

If URL query string contains &foo=& - replace with '&'
But if query string contains &foo=bar& - do nothing and skip to the next variable. 


The current form is bookmarkable using the following URL:
https://bugzilla.mozilla.org/enter_bug.cgi?alias=&assigned_to=ui%40bugzilla.bugs&blocked=&bug_file_loc=http%3A%2F%2F&bug_severity=normal&bug_status=NEW&comment=&component=User%20Interface&contenttypeentry=&contenttypemethod=autodetect&contenttypeselection=text%2Fplain&data=&dependson=&description=&flag_type-254=X&flag_type-38=X&flag_type-594=X&flag_type-643=X&flag_type-7=X&flag_type-731=X&flag_type-74=X&flag_type-786=X&flag_type-793=X&flag_type-800=X&flag_type-812=X&flag_type-813=X&form_name=enter_bug&keywords=&maketemplate=Remember%20values%20as%20bookmarkable%20template&op_sys=Linux&priority=--&product=Bugzilla&qa_contact=default-qa%40bugzilla.bugs&rep_platform=x86&requestee_type-254=&requestee_type-7=&requestee_type-800=&short_desc=&status_whiteboard=&target_milestone=---&version=unspecified

… While it can be shorted to the following by emitting defaults and empty variables:
https://bugzilla.mozilla.org/enter_bug.cgi?component=User%20Interface&form_name=enter_bug&product=Bugzilla

Comment 1

5 years ago
It's true that empty values should not be included, but in your example, the long URL doesn't reduce itself to product=Bugzilla. You still have assigned_to=ui@bugzilla.bugs, bug_severity=normal, bug_status=NEW, etc... which are all set when you clicked the "remember values" link. So your URL would still be very long.

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 594928
You need to log in before you can comment on or make changes to this bug.