Open Bug 844437 Opened 9 years ago Updated 4 years ago

Messages with an empty references header are wrongly threaded together

Categories

(Thunderbird :: Folder and Message Lists, defect)

17 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

UNCONFIRMED

People

(Reporter: pad, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130201065344

Steps to reproduce:

Received many unrelated messages with a References header set but empty ("References: <>") while using the (normal) threaded view.


Actual results:

Those messages are listed in the same thread, as if they were part of the same conversation.


Expected results:

Those messages should have each spawned their own thread, as they are unrelated.
https://hg.mozilla.org/mozilla-central/rev/fc7bd8b3cb09
https://hg.mozilla.org/mozilla-central/rev/10b24d689f27
Assignee: nobody → nalexander
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 22.0
This bug was mis-marked. Fixing. See Bug 844347.
Assignee: nalexander → nobody
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
Target Milestone: Thunderbird 22.0 → ---
same as bug 604319?
Flags: needinfo?(pad)
(In reply to Wayne Mery (:wsmwk) from comment #3)
> same as bug 604319?

I'm not so sure of that. The bug you mention seems to be occuring when the threading is not strict and a client replies by adding "R: " to the begining of the subject. (The autor is talking about references, but his "steps to reproduce" are only dealing with subject threading).
My problem is a bit simpler and is using strict_threading = true.
Flags: needinfo?(pad)
Does this still reproduce for you when using current version of Thunderbird?
Flags: needinfo?(pad)
Flags: needinfo?(jik)
Still happens in 2018-01-01 Daily.
Flags: needinfo?(pad)
Flags: needinfo?(jik)
You need to log in before you can comment on or make changes to this bug.