packaging after build fails, if configure with --disable-updater

RESOLVED FIXED in Thunderbird 22.0

Status

Thunderbird
Build Config
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Christoph Göhre, Assigned: Christoph Göhre)

Tracking

Trunk
Thunderbird 22.0
All
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
If I build Thunderbird with '--disable-updater', the packaging at the end of the build process ends up with missing files. Here is the build log:

/BUILD/objdir-tb-release/_virtualenv/bin/python /BUILD/mozilla/toolkit/mozapps/installer/packager.py -DMOZ_GLUE_IN_PROGRAM -DMOZ_THUNDERBIRD=1 -DOSTYPE=\"Linux3.2\" -DOSARCH=Linux -DNO_NSPR_10_SUPPORT -DAB_CD=en-US -DMOZ_APP_NAME=thunderbird -DPREF_DIR=defaults/pref -DMOZ_ENABLE_GNOME_COMPONENT=1 -DMOZ_GTK2=1 -DJAREXT= -DMOZ_CHILD_PROCESS_NAME=plugin-container -DDLL_PREFIX=lib -DDLL_SUFFIX=.so -DBIN_SUFFIX= -DBINPATH=bin \
                --format omni \
                --removals /BUILD/mail/installer/removed-files.in \
                 \
                 \
                --jarlogs /BUILD/objdir-tb-release/mail/installer/../../jarlog//en-US \
                --optimizejars \
                 \
                package-manifest ../../mozilla/dist ../../mozilla/dist/thunderbird \
                --non-resource defaults/messenger/mailViews.dat
Error: /BUILD/objdir-tb-release/mail/installer/package-manifest:29: Missing file(s): bin/update.locale
Error: /BUILD/objdir-tb-release/mail/installer/package-manifest:30: Missing file(s): bin/updater.ini
Error: /BUILD/objdir-tb-release/mail/installer/package-manifest:57: Missing file(s): bin/update-settings.ini
Error: /BUILD/objdir-tb-release/mail/installer/package-manifest:62: Missing file(s): bin/icons/*.png
Error: /BUILD/objdir-tb-release/mail/installer/package-manifest:586: Missing file(s): bin/updater

So I prepare a patch, which adds more ifdefs in mail/installer/package-manifest.in to get ride of this problem. In bug 736770 the problem was fixed for the Firefox browser.
(Assignee)

Comment 1

4 years ago
Created attachment 717521 [details] [diff] [review]
add more ifdefs in package-manifest.in
Attachment #717521 - Flags: review?(mozilla)

Updated

4 years ago
Attachment #717521 - Flags: review?(mozilla) → review?(mbanner)
Attachment #717521 - Flags: review?(mbanner) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/40064e2e3e80
Assignee: nobody → chris
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 22.0
You need to log in before you can comment on or make changes to this bug.