win32 custom install reveals talkback component to be 2kb in size

VERIFIED DUPLICATE of bug 81866

Status

SeaMonkey
Installer
P3
normal
VERIFIED DUPLICATE of bug 81866
17 years ago
14 years ago

People

(Reporter: Mike Jaques, Assigned: Sean Su)

Tracking

Trunk
mozilla0.9.3
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
This is a wrong calculation or arbitrary number as talkback is atleast 400 kb in
size, not 2kb.

Comment 1

17 years ago
Last time I looked talkback wasn't in the installer, but only a dummy talkback 
item.
Did you check it actually installed Talkback?
I think the 2kb is the correct size for the talkback item, the real bug is 
probably 'Installer doesn't install talkback'.

Comment 2

17 years ago
ccing jon and leaf. 
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

17 years ago
the real bug is probably that you took a mozilla build at a time between when
the empty mozilla talkback.xpi is replaced with an actual talkback xpi (there is
a 1-2 hour window after a mozilla build is completed before the talkback bits
show up).

Without having a url to the file you were using to install the work we can do on
this is limited.

cc'ing syd for installer love.
(Reporter)

Comment 4

17 years ago
no, the build physically has the talkback bits (talkbacm.exe talkbaback.dll 
talkback.hlp), it always seems to show only as 2kb in the installer.

The build number is win32 2001060620 mozilla-win32-installer-sea-talkback.exe

 but i've noticed it for a long time, as i ALWAYS do a custom install and take 
out chatzilla and mailnew.
(Reporter)

Comment 5

17 years ago
nm the dll, thought there was one, my mistake.   the EXE and HLP and CNT  files
are there tho.  Sorry for the spam.

Comment 6

17 years ago
ok, so inside the mozilla installer itself it shows 2Kb as the size of the file. 
 That's to be expected since the mozilla talkback.xpi is empty (2k).  We replace 
it with the Netscape talkback.xpi so that it has the actual usable files.

This is a cosmetic bug only (as far as I know).  If we fix this, it will require 
hard coding the size of the talkback.xpi into the installer config file.

reassigning to default installer component owner.  namachi can't fix this.
Assignee: namachi → ssu
Component: Talkback → Installer
Priority: -- → P3
QA Contact: chofmann → gemal
Target Milestone: --- → mozilla0.9.3
(Assignee)

Comment 7

17 years ago
bug 81866 will fix this problem.  It will hard code the correct talkback size 
information required by the installer.

*** This bug has been marked as a duplicate of 81866 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 8

17 years ago
verified duplicate
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.