If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

pdfjs.disabled = true and external handler set to 'always ask' doesn't ask

RESOLVED WORKSFORME

Status

()

Firefox
File Handling
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: Douglas Bagnall, Unassigned)

Tracking

19 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130218103006

Steps to reproduce:

pdfjs was not quite working well enough for me (e.g. bug #799695), so I tried to restore my previous set-up.

I set pdfjs.disabled to true in about:config.

I ensured that application/pdf was set to 'always ask' in the application preferences.



Actual results:

PDFs were silently saved to disk.



Expected results:

I should have been asked whether I wanted to open the pdf in evince (or whatever) instead of saving it, with my previous selection being the default option.
(Reporter)

Comment 1

5 years ago
A workaround seems to be to stop firefox and remove the 'NC:handleInternal="true"' attribute from the application/pdf entry in mimeTypes.rdf.  Pseudo-patch:

   <RDF:Description RDF:about="urn:mimetype:handler:application/pdf"
-                   NC:handleInternal="true"
                    NC:alwaysAsk="true" />
The right thing is not to change the pdfjs.disabled pref but rather change only the application settings
Component: Untriaged → File Handling
(Reporter)

Comment 3

5 years ago
> rather change only the application settings

Thanks Matthias. I am pretty sure I tried that first, but it didn't work. The setting wasn't changeable. So that is a something more like #815585, which I can't seem to reproduce.
If I do the following, with the latest Nightly (build ID: 20130224031053) on a Ubuntu 12.04 32-bit machine:

1) set application/pdf to 'always ask'
2) open a .pdf file

I get this behavior: the dialog that asks me if I want to open or save the file shows up. (so, the .pdf file isn't automatically saved on the disk)

Comment 5

5 years ago
(In reply to Manuela Muntean [:Manuela] [QA] from comment #4)
> If I do the following, with the latest Nightly (build ID: 20130224031053) on
> a Ubuntu 12.04 32-bit machine:
> 
> 1) set application/pdf to 'always ask'
> 2) open a .pdf file
> 
> I get this behavior: the dialog that asks me if I want to open or save the
> file shows up. (so, the .pdf file isn't automatically saved on the disk)

I can't find a list of build ID's versus releases, or whether they're very strictly in order for nightly/release. But I have version 19.0.2, with build ID 20130307023931 (higher than what you mentioned) installed.

For me having 'pdfjs.disabled = false' and 'always ask' does not prompt me. I guess that feature simply hasn't made it to release yet.

And if it does there should be an option 'use internal' in the dropdown? Though the workaround config mentioned by Douglas doesn't seem logical in that regard since it has two of the settings where the UI would only let you set one.
Ubuntu 12.04 32-bit machine:

If you want to open the .pdf files inline (using pdf.js), all you need to do is go to Edit -> Preferences -> Applications, and choose for PDF the action "Preview in Firefox". This feature has been released and works in Firefox 19.0.2.

On the other hand, if you set pdfjs.disabled to true in about:config and ensure that application/pdf is set to 'always ask' in the application preferences, once you try to open a .pdf file, this is automatically saved to the disk. (Firefox 19.0.2)


But if you simply set application/pdf to 'always ask' and then open a .pdf file, the dialog that asks if you want to open or save the file shows up. (so, the .pdf file isn't automatically saved on the disk)  (Firefox 19.0.2)

Comment 7

5 years ago
Apologies, I guess I had some settings crossing each other. I guess I needed to switch the disabled state a bit and/or fiddle with the application setting, for the 'ask' dialog to show up.

Works in Firefox 19.0.2 Windows 7 64bit.
> On the other hand, if you set pdfjs.disabled to true in about:config and
> ensure that application/pdf is set to 'always ask' in the application
> preferences, once you try to open a .pdf file, this is automatically saved
> to the disk. (Firefox 19.0.2)

If you have installed a program for opening .pdf files (like Acrobat Reader, for example), after following the above steps in 19.0.2, the dialog that asks if you want to open or save the file shows up. (so, the .pdf file isn't automatically saved on the disk)
Closing this, but please reopen the bug if anyone can still reproduce the issue. Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.