Closed Bug 844526 Opened 9 years ago Closed 9 years ago

multiple tabs open and scrolling to the bottom or right side makes it is impossible to switch tabs

Categories

(Firefox for Android Graveyard :: General, defect)

22 Branch
ARM
Android
defect
Not set
normal

Tracking

(firefox21 unaffected, firefox22+ fixed, fennec22+)

RESOLVED FIXED
Firefox 22
Tracking Status
firefox21 --- unaffected
firefox22 + fixed
fennec 22+ ---

People

(Reporter: suirtemedb, Assigned: lucasr)

References

Details

(Keywords: regression, reproducible)

Attachments

(1 file)

Using the nexus 4 in landscape and having 4+ tabs open so you can scroll between the tabs. Scrolling and causing the blue overscroll to happen makes it impossible to switch tabs.
It also is impossible to swipe away open tabs.
(In reply to Demetrius Schwab from comment #1)
> It also is impossible to swipe away open tabs.

Looks like the swipe away is now upwards in landscape.
I don't understand this bug. I have a Nexus 4 too; I opened 8 tabs and am able to scroll and access each.
Scrolling all the way and causing the blue over scroll by a lot keeps the vertical scrolling lock on it appears.
Still don't understand what you're referring to. Can you post a video clip or steps to reproduce? When I scroll left and right I see the blue over scroll that's not preventing one from going back and fort through my 8 tabs. What am I missing?
https://www.youtube.com/watch?v=fm5nGWqdVcQ&feature=youtube_gdata_player There is the bug replicated on my nexus 7 I just don't have a camera or root on my nexus 4 yet so I can't record it in there.
Speculative blocking bug 817735; Demetrius since you can reproduce, can you try a build from Nightly on the 21st http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/2013-02-21-07-20-44-mozilla-central-android/fennec-22.0a1.multi.android-arm.apk, and compare it with a build from the 23rd with bug 817735; http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/2013-02-23-03-11-57-mozilla-central-android/fennec-22.0a1.multi.android-arm.apk ?
Assignee: nobody → lucasr.at.mozilla
Blocks: 817735
Status: UNCONFIRMED → NEW
tracking-fennec: --- → ?
Ever confirmed: true
The bug is only reproducible on the build from the 23rd and not the 21st. That is also when I first noticed it as well.
I think can reproduce this. http://www.youtube.com/watch?v=M6eB3jxfdko

* Have a few tabs open
* Swipe a tab down to close it but let go of it in the tab tray (it does not close)
* Swipe left or right till you get the holo glow
* try to switch tabs
Keywords: reproducible
(In reply to Kevin Brosnan [:kbrosnan] from comment #9)
> I think can reproduce this. http://www.youtube.com/watch?v=M6eB3jxfdko
> 
> * Have a few tabs open
> * Swipe a tab down to close it but let go of it in the tab tray (it does not
> close)
> * Swipe left or right till you get the holo glow
> * try to switch tabs

Can we get a regression window?
See the blocking bug.
tracking-fennec: ? → 22+
(In reply to Alex Keybl [:akeybl] from comment #10)
> (In reply to Kevin Brosnan [:kbrosnan] from comment #9)
> > I think can reproduce this. http://www.youtube.com/watch?v=M6eB3jxfdko
> > 
> > * Have a few tabs open
> > * Swipe a tab down to close it but let go of it in the tab tray (it does not
> > close)
> > * Swipe left or right till you get the holo glow
> > * try to switch tabs
> 
> Can we get a regression window?

This is very likely caused by the new widget we're using on the tabs tray. Investigating.
tracking-fennec: 22+ → ?
tracking-fennec: ? → 22+
(In reply to Kevin Brosnan [:kbrosnan] from comment #11)
> See the blocking bug.

Wanted to make sure you're seeing the same issue.
This can happen in portrait mode as well. The user just needs to open more tabs.
Summary: In landscape and having multiple tabs open and scrolling to the far side makes it is impossible to switch tabs. → multiple tabs open and scrolling to the bottom or right side makes it is impossible to switch tabs
Duplicate of this bug: 847968
Attachment #723551 - Flags: review?(mark.finkle) → review+
https://hg.mozilla.org/mozilla-central/rev/29f9c2b3c4ae
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 22
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.