e.me apps swiping performance is poor

VERIFIED FIXED

Status

Firefox OS
Gaia::Everything.me
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Evyatar 'Tron' Amitay (everything.me), Assigned: Evyatar 'Tron' Amitay (everything.me))

Tracking

unspecified
x86_64
Linux
Bug Flags:
in-moztrap -

Firefox Tracking Flags

(blocking-b2g:tef+, b2g18 fixed, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 fixed)

Details

Attachments

(3 attachments)

When swiping apps- either in a Smart Folder or as search results, the scrolling FPS is very low. Also panning in and out of e.me while apps are displayed is junky.

A fix was made to the Smart Folders list to draw them using canvas (instead of styled HTML elements)- need to implement the same on search results.
Created attachment 717603 [details]
Patch - redirect to github PR

same treatment as the smart folders got- creating the same icon+text using a canvas element.
Attachment #717603 - Flags: review?(crdlc)
Created attachment 717762 [details]
Current state
Created attachment 717763 [details]
After patch

Small font size and less space between icons and app names. Is it intentional?
no, you're right- it was something I overlooked when translating the sizes to JS.
fixed now.
is it fixed?
Status: NEW → ASSIGNED
yeah, as stated in comment #4 :)
Comment on attachment 717603 [details]
Patch - redirect to github PR

perfect!
Attachment #717603 - Flags: review?(crdlc) → review+
https://github.com/mozilla-b2g/gaia/commit/b1911fb712f5e0cc833c612d29d622883870f58b
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Comment on attachment 717603 [details]
Patch - redirect to github PR

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: bad fps scrolling
Testing completed: yes
Risk to taking this patch (and alternatives if risky): low risk, basically html code converted to canvas elements
String or UUID changes made by this patch:
Attachment #717603 - Flags: approval-gaia-v1?
Comment on attachment 717603 [details]
Patch - redirect to github PR

Let's get this on v1.1 first and have some qa verification.  Can we also get some data on the performance improvement here before we commit to taking it on v1.0.1?
Attachment #717603 - Flags: approval-gaia-v1? → approval-gaia-v1+
blocking-b2g: --- → tef?
status-b2g18: --- → affected
status-b2g18-v1.0.0: --- → wontfix
status-b2g18-v1.0.1: --- → affected
Performance:

1) similar to bug #842213 which improved panning when viewing smart folders, this one improves panning while viewing search results. so in that regard it's the same.
2) scrolling of apps- whether in a smart folder or search results- was at around 17FPS. after this change it's at around 28FPS (both figures on ottoro), so this is a big boost UX-wise.
v1-train: dca2744
status-b2g18: affected → fixed
We decided not to take the risk of uplifting bug 842213 and will have to do the same here. It's too close to the ship date now to take on these performance fixes without enough time to test properly on builds.
blocking-b2g: tef? → -
status-b2g18-v1.0.1: affected → wontfix
Partners have not backed this out of their branches despite our concerns around late risk, so let's leave v1.0.1 marked as affected on our side and wait to make a final decision along with bug 842213.
blocking-b2g: - → tef?
status-b2g18-v1.0.1: wontfix → affected
blocking-b2g: tef? → tef+
I was not able to uplift this bug to v1-train and v1.0.1.  If this bug has dependencies which are not marked in this bug, please comment on this bug.  If this bug depends on patches that aren't approved for v1-train and v1.0.1,we need to re-evaluate the approval.  Otherwise, if this is just a merge conflict, you might be able to resolve it with:

  git checkout v1-train
  git cherry-pick -x -m1 b1911fb712f5e0cc833c612d29d622883870f58b
  <RESOLVE MERGE CONFLICTS>
  git commit
  git checkout v1.0.1
  git cherry-pick -x $(git log -n1 v1-train)
Evyatar please follow the instructions
should I push v1-train and v1.0.01 after I'm done?
John- it already exists in v1-train
https://github.com/mozilla-b2g/gaia/commit/dca2744fac289769c22993d458071dd3ce497063

should I continue to cherry-pick from v1-train to v1.0.1?

are these the commands I need to run now?
git checkout v1.0.1
git cherry-pick -x dca2744fac289769c22993d458071dd3ce497063
John- waiting on how to proceed.
Flags: needinfo?(jhford)
(In reply to Evyatar 'Tron' Amitay (everything.me) from comment #18)
> John- it already exists in v1-train
> https://github.com/mozilla-b2g/gaia/commit/
> dca2744fac289769c22993d458071dd3ce497063
> 
> should I continue to cherry-pick from v1-train to v1.0.1?
> 
> are these the commands I need to run now?
> git checkout v1.0.1
> git cherry-pick -x dca2744fac289769c22993d458071dd3ce497063

Hey, I didn't see that commit.  Yes, those are the commands that you'd need to run.  There are a couple merge conflicts on v1.0.1 with dca2744fac289769c22993d458071dd3ce497063, so please resolve and push the resolution to v1.0.1
Flags: needinfo?(jhford)
cherry-picked and pushed- can you please take a look and verify everything's in order? my first time pushing to v1.0.1, wanna make sure I didn't mess up.

are we going to give #842213 the same treatment now?
Flags: needinfo?(crdlc)
I guess that the treatment is the same for bug 842213 but if John won't need your help, this process is not yours I think
Flags: needinfo?(crdlc)
(Assignee)

Updated

5 years ago
Duplicate of this bug: 844564
(In reply to Evyatar 'Tron' Amitay (everything.me) from comment #21)
> cherry-picked and pushed- can you please take a look and verify everything's
> in order? my first time pushing to v1.0.1, wanna make sure I didn't mess up.
> 
> are we going to give #842213 the same treatment now?

Can you please include the commit id here?
It looks reasonable, but without knowing the code, I can't really comment as to its correctness.
status-b2g18-v1.0.1: affected → fixed
no problem, just wanted to make sure I didn't mess anything up with git.

Comment 28

5 years ago
does not make sense to create a regression issue.
Flags: in-moztrap-

Comment 29

5 years ago
Verified Fixed on Unagi:
Swiping of apps and panning in and out of everything.me while apps are displayed does not slowdown.
Unagi Build ID: 20130329070203
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/56c922308fd1
Gaia: 0a9f78bffafda93a159c1f502e8b110c2f49a500
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.