Mozilla will not install with ActiveState Komodo open

VERIFIED WORKSFORME

Status

SeaMonkey
Installer
VERIFIED WORKSFORME
17 years ago
13 years ago

People

(Reporter: Aaron Kaluszka, Assigned: Curt Patrick (gone))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.1+)
Gecko/20010606
BuildID:    2001060620

Mozilla will not install when ActiveState Komodo is open

Reproducible: Always
Steps to Reproduce:
1. Run Komodo
2. Run Mozilla Installer


Actual Results:  Installer complains about an instance of Mozilla being open

Expected Results:  Installer should ignore Komodo

Comment 1

17 years ago
does having Komodo open lock any mozilla files? If so, the installer cannot 
replace the files.
(Reporter)

Comment 2

17 years ago
It runs files out of its own directory which includes a full distro of 
Mozilla.  I'm sure it has files locked.. but these are files that will not get 
overwritten unless somebody explicitly sets the install directory to the one 
under Komodo's.  Perhaps Mozilla instance checking should be handled 
differently.

Comment 3

17 years ago
The problem is that the installer is looking for a window with a classname of:
  MozillaWindowClass

to see if mozilla is running.  It looks like ActiveState Komodo uses the same 
window class name.

I'm not sure where the fix should be:
 1) change the installer to check something else for a running mozilla
 2) change the window class name used by ActiveState Komodo

I'm leaning towards 2), but I have a biased opinion.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Comment 4

17 years ago
over to Curt.
Assignee: ssu → curt
Status: ASSIGNED → NEW

Comment 5

16 years ago
I just had ActiveStats Komodo 1.2 open and Mozilla installs just fine!
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
This was fixed by the patch that made it so Netscape could be installed while
Mozilla (or other Gecko client like AOL) was running.

Comment 7

16 years ago
Verified WFM. 

Dupe of bug 110872? 
Remove startup check for browser instances
Status: RESOLVED → VERIFIED
QA Contact: bugzilla → ktrina
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.