If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

startup crash in nsSocketTransportService::Poll

RESOLVED WORKSFORME

Status

()

Core
Networking
--
critical
RESOLVED WORKSFORME
5 years ago
2 years ago

People

(Reporter: Scoobidiver (away), Unassigned)

Tracking

({crash, regression, steps-wanted})

20 Branch
x86
Windows 7
crash, regression, steps-wanted
Points:
---

Firefox Tracking Flags

(firefox19 unaffected, firefox20- affected, firefox21- affected)

Details

(Whiteboard: [startupcrash], crash signature)

(Reporter)

Description

5 years ago
It's currently #19 top crasher in the first day of 20.0b1 with many duplicates.

Signature 	PR_IntervalToSeconds | nsSocketTransportService::Poll(bool, unsigned int*) More Reports Search
UUID	20a064f4-89a6-466a-86bd-8a3b82130222
Date Processed	2013-02-22 21:44:15
Uptime	2
Last Crash	53.7 minutes before submission
Install Age	1.4 hours since version was first installed.
Install Time	2013-02-22 20:21:05
Product	Firefox
Version	20.0
Build ID	20130220104816
Release Channel	beta
OS	Windows NT
OS Version	6.1.7601 Service Pack 1
Build Architecture	x86
Build Architecture Info	GenuineIntel family 6 model 15 stepping 13
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0x6902958c
App Notes 	
AdapterVendorID: 0x10de, AdapterDeviceID: 0x0641, AdapterSubsysID: 00000000, AdapterDriverVersion: 9.18.13.697
D2D? D2D+ DWrite? DWrite+ D3D10 Layers? D3D10 Layers+ 
Processor Notes 	sp-processor02.phx1.mozilla.com_25943:2008
EMCheckCompatibility	True
Adapter Vendor ID	0x10de
Adapter Device ID	0x0641
Total Virtual Memory	2147352576
Available Virtual Memory	1790836736
System Memory Use Percentage	33
Available Page File	5281329152
Available Physical Memory	2147450880

Frame 	Module 	Signature 	Source
0 	nspr4.dll 	PR_IntervalToSeconds 	nsprpub/pr/src/misc/prinrval.c:84
1 	xul.dll 	nsSocketTransportService::Poll 	netwerk/base/src/nsSocketTransportService2.cpp:398
2 	xul.dll 	nsSocketTransportService::DoPollIteration 	netwerk/base/src/nsSocketTransportService2.cpp:772
3 	xul.dll 	nsSocketTransportService::Run 	netwerk/base/src/nsSocketTransportService2.cpp:642
4 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:627
5 	xul.dll 	nsThread::ThreadFunc 	xpcom/threads/nsThread.cpp:265
6 	nspr4.dll 	_PR_NativeRunThread 	nsprpub/pr/src/threads/combined/pruthr.c:395
7 	nspr4.dll 	pr_root 	nsprpub/pr/src/md/windows/w95thred.c:90
8 	msvcr100.dll 	_callthreadstartex 	f:\dd\vctools\crt_bld\self_x86\crt\src\threadex.c:314
9 	msvcr100.dll 	_threadstartex 	f:\dd\vctools\crt_bld\self_x86\crt\src\threadex.c:292
10 	kernel32.dll 	BaseThreadInitThunk 	
11 	ntdll.dll 	__RtlUserThreadStart 	
12 	ntdll.dll 	_RtlUserThreadStart

More reports at:
https://crash-stats.mozilla.com/report/list?signature=PR_IntervalToSeconds+|+nsSocketTransportService%3A%3APoll%28bool%2C+unsigned+int*%29
(Reporter)

Comment 1

5 years ago
It's #10 top browser crasher in 20.0.
tracking-firefox20: --- → ?
Keywords: topcrash

Updated

5 years ago
Keywords: needURLs, steps-wanted
Adding needinfo on Kairo to help with Url's or any co-relations that may be helpful here.

Kairo, would also be helpful to know how many unique users are being impacted here based on the installations. Thanks !
Flags: needinfo?(kairo)
Some correlations:

PR_IntervalToSeconds | nsSocketTransportService::Poll(bool, unsigned int*)|EXCEPTION_ACCESS_VIOLATION_READ (248 crashes)
    100% (248/248) vs.  15% (11248/74545) wtsapi32.dll
     98% (243/248) vs.  58% (43479/74545) feclient.dll
    100% (248/248) vs.  62% (46141/74545) firefox.exe
    100% (248/248) vs.  62% (46151/74545) xpcom.dll
     98% (244/248) vs.  61% (45266/74545) browsercomps.dll
    100% (248/248) vs.  63% (46937/74545) dbghelp.dll
    100% (248/248) vs.  69% (51346/74545) mswsock.dll
     44% (109/248) vs.  16% (12203/74545) winsta.dll
     57% (142/248) vs.  31% (22803/74545) WSHTCPIP.DLL
     57% (142/248) vs.  33% (24837/74545) Wldap32.dll
     68% (168/248) vs.  44% (32918/74545) t2embed.dll
     52% (129/248) vs.  29% (21653/74545) DWrite.dll
     90% (222/248) vs.  69% (51432/74545) normaliz.dll
     49% (121/248) vs.  29% (21745/74545) wship6.dll
     65% (161/248) vs.  46% (34530/74545) ntmarta.dll
     44% (109/248) vs.  27% (19811/74545) NapiNSP.dll
     44% (109/248) vs.  27% (19819/74545) pnrpnsp.dll
     44% (109/248) vs.  27% (19852/74545) nlaapi.dll
     33% (82/248) vs.  16% (11799/74545) SensApi.dll
     72% (178/248) vs.  55% (40688/74545) softokn3.dll
     72% (179/248) vs.  56% (41842/74545) winrnr.dll
     83% (207/248) vs.  68% (50574/74545) secur32.dll
     70% (174/248) vs.  55% (40664/74545) nssdbm3.dll
     60% (149/248) vs.  45% (33302/74545) rasapi32.dll
     60% (149/248) vs.  45% (33307/74545) rasman.dll
     60% (149/248) vs.  45% (33437/74545) rtutils.dll
     30% (74/248) vs.  15% (11061/74545) oleacc.dll
     78% (194/248) vs.  64% (47481/74545) dnsapi.dll
     67% (165/248) vs.  53% (39477/74545) nssckbi.dll
     26% (65/248) vs.  13% (9511/74545) cryptdll.dll
     68% (168/248) vs.  55% (40630/74545) freebl3.dll
     23% (58/248) vs.  10% (7606/74545) WLIDNSP.DLL
     58% (144/248) vs.  45% (33854/74545) mpr.dll
     15% (37/248) vs.   3% (1946/74545) ntdsapi.dll
     91% (226/248) vs.  79% (58898/74545) iertutil.dll
     37% (91/248) vs.  25% (18844/74545) RpcRtRemote.dll
     81% (200/248) vs.  69% (51616/74545) wintrust.dll
     11% (28/248) vs.   2% (1331/74545) msxml6.dll
     21% (52/248) vs.  11% (8550/74545) mdnsNSP.dll
     11% (27/248) vs.   2% (1168/74545) dsrole.dll
      9% (23/248) vs.   1% (476/74545) GoogleDesktopNetwork3.dll
     32% (79/248) vs.  23% (17455/74545) explorerframe.dll
     32% (79/248) vs.  23% (17499/74545) dui70.dll
     75% (187/248) vs.  67% (50087/74545) msctf.dll
    100% (248/248) vs.  92% (68429/74545) wininet.dll
     37% (91/248) vs.  28% (21241/74545) cryptsp.dll
     32% (79/248) vs.  24% (17877/74545) duser.dll
     17% (41/248) vs.   9% (6536/74545) msctfime.ime
     12% (30/248) vs.   4% (3235/74545) tiptsf.dll
     43% (106/248) vs.  35% (26381/74545) wshtcpip.dll
     43% (106/248) vs.  35% (26389/74545) hnetcfg.dll
     31% (77/248) vs.  24% (17688/74545) msv1_0.dll
     36% (90/248) vs.  29% (21659/74545) tapi32.dll
     16% (39/248) vs.   9% (6680/74545) wshbth.dll
     12% (29/248) vs.   6% (4138/74545) AudioEng.dll
     11% (27/248) vs.   5% (3679/74545) sxs.dll
      9% (22/248) vs.   4% (2622/74545) sprotector.dll
    100% (248/248) vs.  95% (70730/74545) netapi32.dll


A fair number of the URLs seem to be searches:

121 	about:home
99 	about:blank
6 	jar:file:///C:/Programmi/Mozilla%20Firefox/omni.ja!/chrome/browser/content/brows
6 	about:sessionrestore
5 	jar:file:///C:/Program%20Files/Mozilla%20Firefox/omni.ja!/chrome/browser/content
2 	https://www.google.com/search?q=inverno%20a%20kizbhuhel&ie=utf-8&oe=utf-8&aq=t&r
2 	https://www.google.com/search?q=united%20kindom&ie=utf-8&oe=utf-8&aq=t&rls=org.m
2 	https://www.google.com/search?q=SANTANDER&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla
2 	http://www.facebook.com/
2 	file:///C:/Users/Sally/Desktop/Flash/White%20Heart%20Flash%20Reporting%2001.03.1
2 	http://www.bancolombia.com/
2 	file:///C:/Documents%20and%20Settings/Your%20name%20here/Desktop/viewmultiple_ph
1 	http://mail.aol.com/35138-111/aol-6/en-us/Suite.aspx#
1 	http://www.bbc.co.uk/
1 	https://services.addons.mozilla.org/es-ES/firefox/discovery/pane/20.0/WINNT/norm
1 	http://www.google.it/url?sa=i&rct=j&q=&esrc=s&source=images&cd=&docid=wRzRYRYV-q
1 	http://www.microsoft.com/isapi/redir.dll?prd=ie&ar=hotmail
1 	http://en-us.start3.mozilla.com/firefox?client=firefox-a&rls=org.mozilla:en-US:o
1 	http://www.yahoo.com/
1 	https://services.addons.mozilla.org/en-US/firefox/discovery/pane/20.0/WINNT/norm
1 	https://mail.google.com/mail/
1 	http://railways.national-preservation.com/heritage-railways-centres-uk/39867-blu
1 	https://www.virgin-atlantic.com/en/gb/frequentflyer/index.jsp
1 	http://www.talktalk.co.uk/
1 	https://www.google.com/search?q=www.aol.com&ie=utf-8&oe=utf-8&aq=t&rls=org.mozil
1 	http://www.digitallook.com/cgi-bin/digital/portfolio_valuation.cgi?username=anne
1 	http://websearch.ask.com/redirect?client=ff&src=crm&tb=ORJ&o=100000027&locale=en
1 	https://www.google.it/
1 	https://www.google.com/search?q=ocado&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-
1 	http://uk.mg41.mail.yahoo.com/neo/launch?.rand=9r3nlplamem4b
1 	http://posta.eurointerim.it/zimbra/#1
1 	http://search.findeer.com/

1
Keywords: needURLs
(Reporter)

Comment 4

5 years ago
It's not caused by Firefox settings, extensions or HW acceleration according to some comments:
"this keeps happening, safe mode doesnt work either"
"Crashing eveytime I try to open it tonight. I've reset twice without success. Back to Internet Explorer for me."

The only clue I have for those startup crashes is third-party software undetected by correlations. Checking some crash reports doesn't show randomly named DLLs invisible for correlations. Maybe it happens during the load of the faulty DLL or it's caused by LSP.

Windows 8 is unaffected.
this is pretty unactionable as it stands.

Is it a similar problem in > 20?

Comment 6

5 years ago
breakpad=> SELECT version,COUNT(*) as crashes,COUNT(DISTINCT client_crash_date - install_age  * interval '1 second') as installations FROM reports WHERE product='Firefox' AND signature LIKE '%nsSocketTransportService::Poll%' AND utc_day_is(date_processed, '2013-04-07') GROUP BY version;
 version | crashes | installations 
---------+---------+---------------
 11.0    |       2 |             2
 12.0    |       2 |             2
 16.0.2  |       1 |             1
 19.0.2  |       8 |             8
 20.0    |      60 |            39
 21.0    |       4 |             4
 4.0b1   |       1 |             1
 4.0b2   |       5 |             4
 4.0b3   |       1 |             1
 4.0b4   |       1 |             1
 4.0b5   |       2 |             2
 4.0b6   |       2 |             2
 4.0b7   |       2 |             2
(13 rows)

Looks like this is decreasing in volume, though.
Flags: needinfo?(kairo)

Comment 7

5 years ago
(In reply to Patrick McManus [:mcmanus] from comment #5)
> this is pretty unactionable as it stands.
> 
> Is it a similar problem in > 20?

Can you help us to understand what would make this actionable for you, or theories that we can begin to investigate?
(Reporter)

Comment 8

5 years ago
(In reply to Patrick McManus [:mcmanus] from comment #5)
> Is it a similar problem in > 20?
There are no crashes in 21.0 and above but it might be caused by the lack of non-release populations representativeness.

(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #6)
> Looks like this is decreasing in volume, though.
It's indeed only #18 top browser crasher in 20.0. It might spike again after unthrottling 20.0.1 though.
Flags: needinfo?(mcmanus)

Comment 9

5 years ago
(In reply to Scoobidiver from comment #8)
> (In reply to Patrick McManus [:mcmanus] from comment #5)
> > Is it a similar problem in > 20?
> There are no crashes in 21.0 and above but it might be caused by the lack of
> non-release populations representativeness.

But this issue was first found on 20.0b1 - are you suggesting these users have left the beta pool completely?
tracking-firefox21: --- → ?
Keywords: regression
(Reporter)

Comment 10

5 years ago
(In reply to Alex Keybl [:akeybl] from comment #9)
> But this issue was first found on 20.0b1 - are you suggesting these users
> have left the beta pool completely?
There are no crashes in 20.0.1 so either those users are lost for Firefox or they have uninstalled faulty software. I don't know why 20.0 Beta users haven't tried 21.0 Beta. Maybe 21.0 Beta is not affected (21.0a2 was).
Keywords: topcrash
Not tracking for Fx 21 given comment #10. Please renominate if the crash signature appears in top-crash volume on FX21 Beta.

Updated

5 years ago
status-firefox21: --- → unaffected
tracking-firefox21: ? → -
At this point it's pretty clear we won't fix this or respin 20.
tracking-firefox20: ? → -
(Reporter)

Updated

5 years ago
status-firefox21: unaffected → affected
Flags: needinfo?(mcmanus)

Updated

2 years ago
Crash Signature: [@ PR_IntervalToSeconds | nsSocketTransportService::Poll(bool, unsigned int*)] → [@ PR_IntervalToSeconds | nsSocketTransportService::Poll(bool, unsigned int*)] [@ PR_IntervalToSeconds | nsSocketTransportService::Poll]
there is still 612270 , but that doesn't involve PR_IntervalToSeconds.. this is afaict gone.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.