Last Comment Bug 844587 - Commit Access (Level 1) for Carl X. Su
: Commit Access (Level 1) for Carl X. Su
Status: RESOLVED FIXED
:
Product: mozilla.org
Classification: Other
Component: Repository Account Requests (show other bugs)
: other
: All All
: -- normal (vote)
: ---
Assigned To: Rick Bryce [:rbryce]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-24 03:42 PST by Carl X. Su
Modified: 2013-03-01 20:25 PST (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
The public key (274 bytes, application/octet-stream)
2013-02-24 03:42 PST, Carl X. Su
no flags Details
The public key (274 bytes, text/plain)
2013-02-24 03:46 PST, Carl X. Su
no flags Details
The RSA public key (402 bytes, text/plain)
2013-02-25 10:10 PST, Carl X. Su
no flags Details

Description Carl X. Su 2013-02-24 03:42:56 PST
Created attachment 717608 [details]
The public key

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130219185710

Steps to reproduce:

I filed a commit access request here.


Actual results:

A new bug raised.


Expected results:

bcbcarl at google mail should have level 1 commit access.
Comment 1 Carl X. Su 2013-02-24 03:46:37 PST
Created attachment 717609 [details]
The public key

The public key in plain text format.
Comment 2 Josh Matthews [:jdm] 2013-02-24 06:47:56 PST
Hi Carl! You'll need to have somebody with commit access vouch for you in this bug, and you'll need to send a signed form to Shannon as well, per http://www.mozilla.org/hacking/committer/. Leave a comment here when you've done that, please.
Comment 3 Kan-Ru Chen [:kanru] (UTC+8) 2013-02-24 22:13:18 PST
vouch!
Comment 4 Carl X. Su 2013-02-25 02:43:29 PST
I've done that. The Committer's Agreement has been sent to Shannon Armitage.
Comment 5 Carl X. Su 2013-02-25 02:45:00 PST
This request is ready for consideration.
Comment 6 Josh Matthews [:jdm] 2013-02-25 06:33:01 PST
Waiting on Shannon for confirmation.
Comment 7 sarmitage@mozilla.com 2013-02-25 08:49:27 PST
I have received the form.
Comment 8 Josh Matthews [:jdm] 2013-02-25 09:01:15 PST
One L1 account coming up!
Comment 9 Rick Bryce [:rbryce] 2013-02-25 09:30:33 PST
Account created.  One problem exist.  We do not support this type of public ssh key.  Please supply an RSA or DSA public key, then I can finish setting up this account.
Comment 10 Carl X. Su 2013-02-25 10:10:03 PST
Created attachment 717946 [details]
The RSA public key

Okay. This is the RSA public key.
Comment 11 Rick Bryce [:rbryce] 2013-02-25 10:26:24 PST
(In reply to Carl X. Su from comment #10)
> Created attachment 717946 [details]
> The RSA public key
> 
> Okay. This is the RSA public key.

RSA key added.  You should be good to go.
Comment 12 Carl X. Su 2013-03-01 04:47:10 PST
I'm sorry but my public key seems not work.

$ ssh hg.mozilla.org
Permission denied (publickey,keyboard-interactive).

I configured ~/.hgrc and (your-local-hg-root)/.hg/hgrc but still didn't work.
Comment 13 Josh Matthews [:jdm] 2013-03-01 05:41:26 PST
Have you added
>Host hg.mozilla.org
>User carl@moztw.org
to your ~/.ssh/config file?
Comment 14 Carl X. Su 2013-03-01 05:53:09 PST
Sorry I added this:
User <carl@moztw.org>

However, it should be:
User carl@moztw.org

By the way, I registered BugZilla with Gmail account but now I switched to moztw.org. Can I change my email to this one?
Comment 15 Carl X. Su 2013-03-01 07:20:36 PST
I have no clue about my LDAP password. What should I do?
Comment 16 :Gavin Sharp [email: gavin@gavinsharp.com] 2013-03-01 11:36:52 PST
server-ops can reset your LDAP password.
Comment 17 Dumitru Gherman [:dumitru] 2013-03-01 15:49:19 PST
In comment 0, you've requested that your LDAP account to be bcbcarl@gmail.com. Please update your config file accordingly.

I reset your LDAP password, you should have received an email.

For any other problems please file a separate bug, since this bug already fixed what it was asked for.

Thanks!
Comment 18 Carl X. Su 2013-03-01 20:25:49 PST
I changed my password. Thanks.

Note You need to log in before you can comment on or make changes to this bug.