Closed Bug 844590 Opened 8 years ago Closed 8 years ago

java.lang.NullPointerException: at org.mozilla.gecko.util.UiAsyncTask.execute(UiAsyncTask.java)

Categories

(Firefox for Android Graveyard :: General, defect)

22 Branch
ARM
Android
defect
Not set
critical

Tracking

(firefox21 unaffected, firefox22 fixed)

RESOLVED FIXED
Firefox 22
Tracking Status
firefox21 --- unaffected
firefox22 --- fixed

People

(Reporter: scoobidiver, Assigned: bnicholson)

References

Details

(Keywords: crash, regression, Whiteboard: [native-crash])

Crash Data

Attachments

(1 file, 1 obsolete file)

It first showed up in 21.0a1/20130223 and is #2 top crasher in this build. The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=885cde564ff3&tochange=08a034e1d43a
It's likely caused by bug 842797.

java.lang.NullPointerException
	at org.mozilla.gecko.util.UiAsyncTask.execute(UiAsyncTask.java:45)
	at org.mozilla.gecko.AboutHomeContent.loadTopSitesThumbnails(AboutHomeContent.java:424)
	at org.mozilla.gecko.AboutHomeContent.access$200(AboutHomeContent.java:69)
	at org.mozilla.gecko.AboutHomeContent$8.run(AboutHomeContent.java:318)
	at android.os.Handler.handleCallback(Handler.java:605)
	at android.os.Handler.dispatchMessage(Handler.java:92)
	at android.os.Looper.loop(Looper.java:137)
	at android.app.ActivityThread.main(ActivityThread.java:4424)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:511)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:784)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:551)
	at dalvik.system.NativeStart.main(Native Method)

More reports at:
https://crash-stats.mozilla.com/report/list?signature=java.lang.NullPointerException%3A+at+org.mozilla.gecko.util.UiAsyncTask.execute%28UiAsyncTask.java%29
There are currently no crashes in 22.0a1/20130224.
Status: NEW → RESOLVED
tracking-fennec: ? → ---
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 843851
There's a few different stack traces in the crash reports. Bug 843851 fixed the most common one, but we should still deal with the rest.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Keywords: topcrash
Rather than having callers responsible for passing in a Handler (which is apparently error-prone), UiAsyncTask can get the UI thread on its own by using Looper.getMainLooper().

r=kats in IRC
Assignee: nobody → bnicholson
Status: REOPENED → ASSIGNED
Attachment #718120 - Flags: review+
Fixed synchronization and Javadocs
Attachment #718120 - Attachment is obsolete: true
Attachment #718192 - Flags: review+
Whiteboard: [native-crash]
https://hg.mozilla.org/mozilla-central/rev/018649ef8ce6
Status: ASSIGNED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 22
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.