animation of "radius" attribute of feMorphology results in no rendering at all

RESOLVED DUPLICATE of bug 738574

Status

()

defect
RESOLVED DUPLICATE of bug 738574
6 years ago
6 years ago

People

(Reporter: lars.sonchocky-helldorf, Unassigned)

Tracking

19 Branch
x86
macOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Posted image test-mozilla.svg
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130215130331

Steps to reproduce:

I created a SVG file which contains the following filter declaration:
<feMorphology operator = "dilate" radius = "3">  
<animate attributeName = "radius" dur = "30s" values = "10 10; 0 0; 0 0; 0 0; 0 0; 0 0; 0 0" keyTimes = "0; .13; .2; .33; .47; .67; 1" />
</feMorphology>

see also the attached file for reference


Actual results:

As soon as the feMorphology filter element contain the animate tag nothing more is rendered


Expected results:

The attribute should be animated as Google Chrome does it. So if you want to see how it should look like use Google Chrome.
Component: Untriaged → SVG
Product: Firefox → Core
feMorphology works perfectly well. It's <use> that's the problem. We don't propagate the animation to the <use> instances.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 738574
You need to log in before you can comment on or make changes to this bug.